Advanced search  


cpg1.5.44 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.42 or older update to this latest version as soon as possible.

Pages: [1]   Go Down

Author Topic: [Fixed]: Search from keyword manager fails  (Read 5380 times)

0 Members and 1 Guest are viewing this topic.

Leonard Will

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
[Fixed]: Search from keyword manager fails
« on: August 14, 2010, 05:14:49 PM »

I am using 1.5.8 at

The search function from the third column in keyword manager returned no images. Searching from the keyword cloud at the bottom worked correctly.

This seems to be because the line in keywordmgr.php reads

            <a href="thumbnails.php?album=search&amp;search=$orig_word_param" target="_blank">

I changed it to

            <a href="thumbnails.php?album=search&amp;keywords=on&amp;search=$orig_word_param" target="_blank">

and it now works. Is this a bug or should the "keywords=on" text be suppllied from somewhere else?

« Last Edit: August 14, 2010, 07:31:35 PM by François Keller »

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9077
  • aka Frantz
    • Ma galerie
[Fixed]: Re: Search from keyword manager fails
« Reply #1 on: August 14, 2010, 07:31:15 PM »

Thank's for reporting this, you're right
Fixed in rev#7818
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog
Pages: [1]   Go Up

Page created in 0.062 seconds with 21 queries.