Advanced search  

News:

cpg1.5.42 maintenance release - upgrade recommended
The Coppermine development team is releasing an update for Coppermine in order to fix several minor issues. All fixes are not security critical, so if your gallery is running fine with cpg1.5.36, cpg1.5.38 or cpg1.5.40 you don't need to upgrade. If you are running an older version than cpg1.5.36, you must update to this latest version as soon as possible because of the security impact!
[more]

Pages: [1]   Go Down

Author Topic: Read EXIF does not work?  (Read 10727 times)

0 Members and 1 Guest are viewing this topic.

Streamer

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Read EXIF does not work?
« on: August 11, 2010, 09:53:44 PM »

Hi,

I have problem with reading EXIF data. This worked fine with 1.4.x but does not work after upgraded to 1.5.x. I have setting "Read EXIF data in JPEG files" (read_exif_data = 1, checked from database) on and selected some exif data to show from exif manager. Here's link to my gallery http://www.perhokalastajat.net/kuvagalleria/index.php
Logged

Streamer

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Read EXIF does not work?
« Reply #1 on: August 14, 2010, 07:49:45 AM »

Any help for this? Is it working for you or is it just our gallery that has some problem?
Logged

Streamer

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Read EXIF does not work?
« Reply #2 on: August 16, 2010, 08:51:03 PM »

Anyone can confirm if the reading EXIF works or not?
Logged

Nibbler

  • Guest
Re: Read EXIF does not work?
« Reply #3 on: August 19, 2010, 10:18:09 PM »

Please post a link to an image in your gallery that contains EXIF data.
Logged

Streamer

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Read EXIF does not work?
« Reply #4 on: August 22, 2010, 10:57:45 AM »

Seems like the 1.5 is working different with image saving. 1.4.x did not compress jpg's that was not over maximum size, 1.5 does it always without checking image size? Of course then the exif date is removed from picture that is on the server. However I think the exif date should be read before resize / compress, right?

Here's picture uploaded with 1.4.x http://www.perhokalastajat.net/kuvagalleria/displayimage.php?pid=22088
And same picture with 1.5.8: http://www.perhokalastajat.net/kuvagalleria/displayimage.php?pid=22601

Settings
GD version 2.x (on the server it is bundled (2.0.28 compatible))
Use dimension: Max Aspect
Max width or height of an intermediate picture: 800
Max width or height for uploaded pictures (pixels): 2048
Read EXIF data in JPEG files: ON
Auto resize images that are larger than max width or height: Yes: Everyone


Logged

Nibbler

  • Guest
Re: Read EXIF does not work?
« Reply #5 on: August 22, 2010, 03:21:58 PM »

No, the exif data is extracted on demand the first time the picture is viewed and then cached in the database. Any kind of auto resizing or watermarking will interfere with this.
Logged

Streamer

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Read EXIF does not work?
« Reply #6 on: August 22, 2010, 07:58:55 PM »

From documentation

"Therefor, if you resize your pics (this includes creation of intermediate sized images and thumbnails), the exif data embedded into the original will be lost - it will not remain inside the resized image. It will remain though within the exif database table and will be displayed inside the file information section."

And why my pictures are "resized and compressed" if they are not over 800 pixels what's on my settings? It's not now possible to save better quality jpg:s to my gallery, it was possible on 1.4.
Logged

Streamer

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Read EXIF does not work?
« Reply #7 on: August 27, 2010, 07:21:30 PM »

So, any comments after my last post? I think there's some strange on this, is there any users that has read exif working?
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4281
    • Windsurf.me
Re: Read EXIF does not work?
« Reply #8 on: August 27, 2010, 09:27:53 PM »

Yep, works perfectly for me. Your last comment also completely mistifies me.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Streamer

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Read EXIF does not work?
« Reply #9 on: August 30, 2010, 08:35:45 AM »

Ok. So maybe it's some kind of problem with server settings, php version, gd version or something like that.. but anyhow something changed with upgrade to 1.5.. :(
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15211
Re: Read EXIF does not work?
« Reply #10 on: September 02, 2010, 12:42:16 PM »

1.4.x did not compress jpg's that was not over maximum size, 1.5 does it always without checking image size?
I think I recognized that behavior, too. Please post all relevant resizing settings (= all $CONFIG values that are used in the function add_picture in include/picmgmt.inc.php).
Logged

Streamer

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Read EXIF does not work?
« Reply #11 on: September 02, 2010, 07:43:46 PM »

I think I recognized that behavior, too. Please post all relevant resizing settings (= all $CONFIG values that are used in the function add_picture in include/picmgmt.inc.php).

Ok, here's my config values from function add_picture:

$CONFIG['fullpath'] = albums/
$CONFIG['normal_pfx'] = normal_
$CONFIG['thumb_pfx'] = thumb_
$CONFIG['orig_pfx'] = orig_
$CONFIG['allowed_file_extensions'] = GIF/JPG/JPEG/
$CONFIG['max_upl_width_height'] = 1000
$CONFIG['auto_resize'] = 1
$CONFIG['thumb_method'] = gd2
$CONFIG['thumb_use'] = any
$CONFIG['enable_watermark'] = 0
$CONFIG['which_files_to_watermark'] = both
$CONFIG['read_iptc_data'] = 0
$CONFIG['keyword_separator'] = %20
$CONFIG['thumb_width'] = 100
$CONFIG['picture_use'] = any
$CONFIG['picture_width'] = 1000
$CONFIG['make_intermediate'] = 0
$CONFIG['enable_watermark'] = 0
$CONFIG['which_files_to_watermark'] = both
$CONFIG['auto_resize'] = 1
$CONFIG['max_upl_width_height'] = 1000
$CONFIG['allow_guests_enter_file_details'] = 0

Note, I have changed max size from 800 -> 1000 after last posts.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15211
Re: Read EXIF does not work?
« Reply #12 on: September 10, 2010, 04:19:41 PM »

Should work as expected with r7889. Please confirm.
Logged

Streamer

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Read EXIF does not work?
« Reply #13 on: September 10, 2010, 06:46:43 PM »

Works like a dream!!

Thank's a lot, I owe you a beer  ;D
Logged
Pages: [1]   Go Up
 

Page created in 0.073 seconds with 20 queries.