Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: "Floog" for cgp15x  (Read 9864 times)

0 Members and 1 Guest are viewing this topic.

Raven24

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 25
"Floog" for cgp15x
« on: August 03, 2010, 02:21:05 am »

Since I updated my own installation of Coppermine to 1.5 today,
I thought it was the best opportunity to update my theme to the latest version, too.

→ here is the post for the 1.4.x version: http://forum.coppermine-gallery.net/index.php/topic,52637.0.html

→ attached the archive containing the theme

For the new version of my theme (I believe the version number would be 1.4, although I guess the backwards-incompatibility would qualify for 2.0) I first tried what would happen if I just used the old, unmodified theme with the new version of Coppermine. That went surprisingly well, so I decided to modify it towards compatibility to the new release instead of starting from scratch.
I am now at a point where it is useable and so far I am confident that I respected all the changes of v1.5. Of course I was able to improve the theme a little, too.
For instance the round corners work in Mozilla Firefox, all Webkit-based browsers (Google Chrome, Safari) and Opera (guess which browser still doesn't do as CSS commands...).
Also, the size of the blue boxed used for albums and thumbnails is now synchronized by javascript onload and onresize. That should get rid of the awkward white spaces in cases where the boxes were not the same size.
There were also some minor improvements on the display of the admin menus and the single image display page and some other small things.

As always, the theme is designed for use in my own gallery. In hope it will be usefull to others, I am sharing it here. Use at your own risk.
Feedback is always welcome.


I also want to use this chance to congratulate the Coppermine Dev Team to this really great release! Keep up the good work. ;)
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4483
    • Windsurf.me
Re: "Floog" for cgp15x
« Reply #1 on: August 03, 2010, 08:44:22 am »

Thanks for your work. I'll not be able to review and add it to the demo/repository until the weekend. Hopefully one of the other devs can.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4483
    • Windsurf.me
Re: "Floog" for cgp15x
« Reply #2 on: August 20, 2010, 06:23:03 pm »

Demo - Download

Thanks for your contribution.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

donogl

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 12
Re: "Floog" for cgp15x
« Reply #3 on: January 01, 2011, 12:26:26 pm »

Hi,
first of all thanks for making this great theme.
In my eyes it is the first real nice looking theme for Coppermine!

I have updated my galerie to 1.5x yesterday and changed the theme to floog.


But while using the Theme there always appears a Error-Message, when i try to Delete/Edit a Comment an the single-photo-page.

"A valid form token could not be found. "

When i switch back to the standard curve theme, the Error do not appear anymore and everythings seems to work fine.
Only when activating the floog-theme the Errer appears so i quess there is something wrong with the Theme.

Any solution for this problem?

Here is a link to my galery:
http://www.ride-downhill.com/galerie/

When i try to edit or delete f.e. the comment of this picture
http://www.ride-downhill.com/galerie/displayimage.php?album=440&pid=6677

this error appears:
http://www.ride-downhill.com/galerie/delete.php?msg_id=3553&what=comment

Server is a:
5.2.6-2ubuntu4.2
MySQL 5.0.67

Thanks for any kind of help!

Christoph
Logged

donogl

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 12
Re: "Floog" for cgp15x
« Reply #4 on: January 01, 2011, 01:53:58 pm »

I have found now this thread where it is suggested to delete the raw_ip out of the $token-line.

http://forum.coppermine-gallery.net/index.php?topic=65920.0

In which file can i find this line to edit it and to try if this will fix the problem?
Logged

donogl

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 12
Re: "Floog" for cgp15x
« Reply #5 on: January 02, 2011, 01:15:28 pm »

So now i have played arround a little bit and build out of the Curve-Theme and the Floog-Theme a new Curve-Floog-Greybox-Theme.

http://www.ride-downhill.com/galerie/

It looks nearly like the floog-Design but also seems to work even on IE without any kind of desig-failures.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4483
    • Windsurf.me
Re: "Floog" for cgp15x
« Reply #6 on: January 02, 2011, 05:53:45 pm »

Nice work there. Would be great if you could contribute your work.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

donogl

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 12
Re: "Floog" for cgp15x
« Reply #7 on: January 02, 2011, 07:05:21 pm »

Logged

MarioLaul

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Re: "Floog" for cgp15x
« Reply #8 on: February 03, 2014, 09:39:52 am »

I have problem. Floog theme not show videos, what can i do?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15427
Re: "Floog" for cgp15x
« Reply #9 on: March 04, 2014, 08:42:58 pm »

Floog theme not show videos, what can i do?
Are you sure this is a theme related issue? Have you tested other themes (e.g. "curve" or "water_drop")?
Logged
Pages: [1]   Go Up
 

Page created in 0.052 seconds with 20 queries.