Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Closed]: One Deprecated Errors and Undefined Offset Errors  (Read 8235 times)

0 Members and 1 Guest are viewing this topic.

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20

I hardly ever post here because most of the errors are my fault but these I had nothing to do with. I went to the URL of my gallery (http://www.fluffhouse.org.uk/jakie/robingirl/gallery) and these came up:

Quote
Deprecated: Assigning the return value of new by reference is deprecated in /var/www/jakie/robingirl/gallery/include/debugger.inc.php on line 129

Notice: Undefined offset: 8192 in /var/www/jakie/robingirl/gallery/include/debugger.inc.php on line 112

I had another deprecated error but I found the fix on the forums here. I could not find the fix for these, thats why I'm posting.

I hope I did this right. I'm sorry in advance if I didn't. I don't own my own webhost, a friend does. I have unlimited space...and never had a problem like this before! :)

Oh and I can log in but thanks to these errors I can't add any images, batch upload, look at settings, etc.

Thanks
Robin Gurl
« Last Edit: June 07, 2010, 08:26:58 pm by Phill Luckhurst »
Logged

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: One Deprecated Errors and Undefined Offset Errors
« Reply #1 on: June 07, 2010, 02:44:44 am »

ACTUALLY - UPDATE: I can't sign in. I thought I could. D:
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: One Deprecated Errors and Undefined Offset Errors
« Reply #2 on: June 07, 2010, 07:35:11 am »

You're using cpg1.4.10, so you shouldn't have posted on the bugs board for cpg1.5.x. You're clearly looking for support, as yours is not a valid bug report (you haven't even bothered to read the docs or search the board for the error message you got before posting). Upgrade, you're running behind in version count by 16 versions, so your gallery is vulnerable. As a side-effect, you get the error message that is a result of your webhost upgrading to a very recent PHP version.
Moving from cpg1.5 Testing/Bugs
Logged

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: One Deprecated Errors and Undefined Offset Errors
« Reply #3 on: June 07, 2010, 07:20:25 pm »

Alright. I'm ticked off.  >:( I UPDATED like you said and this is all I got.

' => 'Could not authenticate you', // cpg1.5 'provide_admin_account' => 'Please provide your coppermine admin account details or your mySQL account data', // cpg1.5 'try_again' => 'Try again', // cpg1.5 'mysql_connect_error' => 'Could not create a mySQL connection', // cpg1.5 'mysql_database_error' => 'mySQL could not locate a database called %s', // cpg1.5 'mysql_said' => 'MySQL said', // cpg1.5 'check_config_file' => 'Please check the SQL values in %s', // cpg1.5 'performing_database_updates' => 'Performing Database Updates', // cpg1.5 'already_done' => 'Already Done', // cpg1.5 'password_encryption' => 'Encryption of passwords', // cpg1.5 'alb_password_encryption' => 'Encryption of album passwords', // cpg1.5 'category_tree' => 'Category tree', // cpg1.5 'authentication_needed' => 'Authentication needed', // cpg1.5 'username' => 'Username', // cpg1.5 'password' => 'Password', // cpg1.5 'update_completed' => 'Update completed', // cpg1.5 'check_versions' => 'It\'s recommended to %scheck your file versions%s if you just upgraded from an older version of coppermine', // cpg1.5 // Leave the %s untouched when translating - it wraps the link 'start_page' => 'If you didn\'t (or you don\'t want to check), you can go to %syour gallery\'s start page%s', // cpg1.5 // Leave the %s untouched when translating - it wraps the link 'errors_encountered' => 'The following errors were encountered and need to be corrected first', // cpg1.5 'delete_file' => 'Delete %s', // cpg1.5 'could_not_delete' => 'Could not delete due to missing permissions. Delete the file manually!', // cpg1.5 ); } if (!function_exists('cpg_display_help')) { $help = ' '.cpg_display_help('f=upgrading.htm&as=updater&ae=updater_end&top=1', '650', '500'); } else { $help = ' '; } // ---------------------------- AUTHENTICATION --------------------------- // // SKIP_AUTHENTICATION is a constant that can be defined for users who can't retrieve any kind of password if (!defined('SKIP_AUTHENTICATION') && !$_SESSION['auth']) { html_header($lang_update_php['title']); if (!$superCage->post->keyExists('method')) { //first try to connect to the db to see if we can authenticate the admin test_sql_connection(); if ($errors != '') { //we could not establish an sql connection, so update can't be done (and user can't be autenticated) html_error($errors); } else { //echo a box for admin autentication html_auth_box('admin'); } } elseif ($superCage->post->getAlpha('method') == 'admin') { //try to autenticate the admin test_sql_connection(); $user = $superCage->post->getEscaped('user'); $pass = $superCage->post->getEscaped('pass'); $pass2 = md5($pass); $sql = "SELECT user_active FROM {$CONFIG['TABLE_PREFIX']}users WHERE user_group = 1 AND user_name = '$user' AND (user_password = '$pass' OR user_password = '$pass2')"; $result = @mysql_query($sql); if (!@mysql_num_rows($result)) { //not authenticated, try mysql account details html_auth_box('MySQL'); } else { //authenticated, do the update $_SESSION['auth'] = true; start_update(); } } else { //try to autenticate via MySQL details (in configuration) if ($superCage->post->getEscaped('user') == $CONFIG['dbuser'] && $superCage->post->getEscaped('pass') == $CONFIG['dbpass']) { //authenticated, do the update $_SESSION['auth'] = true; start_update(); } else { //no go, try again html_error($lang_update_php['could_not_authenticate'] . ' - ' . $lang_update_php['try_again'] .''); } } html_footer(); } else { html_header($lang_update_php['title']); $_SESSION['auth'] = true; start_update(); html_footer(); } // function definitions --- start // ------------------------- HTML OUTPUT FUNCTIONS ------------------------- // function html_header($title, $charset = 'iso8859-1') { if (function_exists('pageheader') && defined('COPPERMINE_VERSION') && GALLERY_ADMIN_MODE) { pageheader($title); } else { echo <<< EOT EOT; } } function html_error($error_msg = '') { global $lang_update_php, $help; echo <<< EOT EOT; if ($error_msg) { echo <<< EOT EOT; } echo <<< EOT

Yes it's a lot of type. I didn't want to see it either. I'm trying to find where to enter my info but it's not letting me. And if I messed up again by posting for help in the wrong way then I'm sorry but help me PLEASE? If you do I won't be here again.

I also tried to do version check and got this:

Deprecated: Assigning the return value of new by reference is deprecated in /var/www/jakie/robingirl/gallery/include/debugger.inc.php on line 129

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /var/www/jakie/robingirl/gallery/include/debugger.inc.php on line 131

(the same error as before, wow shocker. D:)

AND before you bitch at me (again) I did read all the documents and followed the upgrade.html to the last step.

Logged

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: One Deprecated Errors and Undefined Offset Errors
« Reply #4 on: June 07, 2010, 07:24:39 pm »

Oh and i just found another page of "errors" from the PHP code if you'd like me to post it here.
Logged

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: One Deprecated Errors and Undefined Offset Errors
« Reply #5 on: June 07, 2010, 07:37:18 pm »

You're using cpg1.4.10, so you shouldn't have posted on the bugs board for cpg1.5.x. You're clearly looking for support, as yours is not a valid bug report (you haven't even bothered to read the docs or search the board for the error message you got before posting). Upgrade, you're running behind in version count by 16 versions, so your gallery is vulnerable. As a side-effect, you get the error message that is a result of your webhost upgrading to a very recent PHP version.
Moving from cpg1.5 Testing/Bugs

I DID use the board for help. I fixed the first deprecated error that way. I have searched for the others. And as seen in my last post, I did upgrade. And got nothing but broken code. I posted to that board because that's where I found the answer to the first "code error".

I'm so glad everyone is so "helpful" around here, makes me so 'happy' I chose coppermine for my gallery. x_x
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4482
    • Windsurf.me
Re: One Deprecated Errors and Undefined Offset Errors
« Reply #6 on: June 07, 2010, 08:25:56 pm »

Joachim was just trying to point out that you had posted in the Bugs board for 1.5 when your was clearly not a bug in 1.5 but a problem with your upgrading. You now have 2 posts regarding the same problem so I will close and lock this one.

Please, be polite to supporters if you want continued support.
Logged
It is a mistake to think you can solve any major problems just with potatoes.
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 21 queries.