Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 ... 3 4 5 6 [7]   Go Down

Author Topic: Coppermine forum plugin (cpgforum) for cpg1.5.x  (Read 61337 times)

0 Members and 1 Guest are viewing this topic.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #120 on: March 19, 2013, 11:33:12 am »

You need to create at least one forum category before you can start threads.
Logged

ninouee

  • Coppermine novice
  • *
  • Country: fr
  • Offline Offline
  • Gender: Female
  • Posts: 31
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #121 on: March 30, 2013, 10:55:40 am »

Hello

Thank you for your answer.

But, how can i creat a category? I search on the first message of this topik and i dont understant how the can do that.
Logged

ninouee

  • Coppermine novice
  • *
  • Country: fr
  • Offline Offline
  • Gender: Female
  • Posts: 31
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #122 on: March 30, 2013, 01:44:51 pm »

Hello, i'm Sorry for the 2 posts but i find my problem: I find where was the forum administrator.

Thank You for your work and the reply!  :)
Logged

computel

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #123 on: January 18, 2014, 06:51:35 pm »

I'm getting this error when I installed the login and looked at the forum or forum manager

Array (
  • => Error Number: 1146 [1] => Table 'archives_arc1.cpg15x_fr_categories' doesn't exist [2] => SELECT * FROM cpg15x_fr_categories ORDER BY cat_order asc )


Thanks
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #124 on: January 19, 2014, 05:54:14 pm »

It seems that you haven't properly installed the plugin. Please try to re-install again and make sure you hit the install button at the installer.
Logged

computel

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #125 on: January 21, 2014, 03:20:10 am »

it's not installing the database from what I can see, As I looked in the database and nothing is added. I downloaded the file again and uploaded still the same problem

Code: [Select]
Performing database updates
CREATE TABLE IF NOT EXISTS `cpg15x_fr_boards` ( `board_id` smallint(5) NOT NULL auto_increment, `cat_id` tinyint(4) NOT NULL default '0', `child_level` tinyint(4) NOT NULL default '0', `parent_id` smallint(5) NOT NULL default '0', `board_order` smallint(5) NOT NULL default '0', `last_msg_id` int(10) NOT NULL default '0', `updated_msg_id` int(10) NOT NULL default '0', `name` tinytext NOT NULL, `description` text NOT NULL, `topics` mediumint(8) NOT NULL default '0', `posts` mediumint(8) NOT NULL default '0', PRIMARY KEY (`board_id`) ) TYPE=MyISAM Already Done
CREATE TABLE IF NOT EXISTS `cpg15x_fr_categories` ( `cat_id` tinyint(4) NOT NULL auto_increment, `cat_order` tinyint(4) NOT NULL default '0', `name` tinytext NOT NULL, PRIMARY KEY (`cat_id`) ) TYPE=MyISAM Already Done
CREATE TABLE IF NOT EXISTS `cpg15x_fr_message_icons` ( `icon_id` smallint(5) NOT NULL auto_increment, `title` varchar(80) NOT NULL default '', `filename` varchar(80) NOT NULL default '', `icon_order` smallint(5) NOT NULL default '0', PRIMARY KEY (`icon_id`) ) TYPE=MyISAM AUTO_INCREMENT=14 Already Done
INSERT INTO `cpg15x_fr_message_icons` (`icon_id`, `title`, `filename`, `icon_order`) VALUES (1, 'Post', 'icon1', 0), (2, 'Smile', 'icon2', 1), (3, 'Big smile', 'icon3', 2), (4, 'Angry', 'icon4', 3), (5, 'Cool', 'icon5', 4), (6, 'Sad', 'icon6', 5), (7, 'Wink', 'icon7', 6), (8, 'Comment', 'icon8', 7), (9, 'Magnify', 'icon9', 8), (10, 'Icon', 'icon10', 9), (11, 'Lamp', 'icon11', 10), (12, 'Bug', 'icon12', 11), (13, 'Wheel', 'icon13', 12) Already Done
CREATE TABLE IF NOT EXISTS `cpg15x_fr_messages` ( `msg_id` int(10) NOT NULL auto_increment, `topic_id` mediumint(8) NOT NULL default '0', `board_id` smallint(5) NOT NULL default '0', `poster_time` int(10) NOT NULL default '0', `poster_id` mediumint(8) NOT NULL default '0', `modified_id` int(10) NOT NULL default '0', `subject` tinytext NOT NULL, `poster_name` tinytext NOT NULL, `poster_email` tinytext NOT NULL, `poster_ip` tinytext NOT NULL, `smileys_enabled` tinyint(4) NOT NULL default '1', `modified_time` int(10) NOT NULL default '0', `modified_name` tinytext NOT NULL, `body` text NOT NULL, `icon` varchar(16) NOT NULL default '1', PRIMARY KEY (`msg_id`) ) TYPE=MyISAM Already Done
CREATE TABLE IF NOT EXISTS `cpg15x_fr_topics` ( `topic_id` mediumint(8) NOT NULL auto_increment, `is_sticky` tinyint(4) NOT NULL default '0', `board_id` smallint(5) NOT NULL default '0', `first_msg_id` int(10) NOT NULL default '0', `last_msg_id` int(10) NOT NULL default '0', `started_member_id` int(8) NOT NULL default '0', `updated_member_id` int(8) NOT NULL default '0', `poll_id` mediumint(8) NOT NULL default '0', `replies` int(10) NOT NULL default '0', `views` int(10) NOT NULL default '0', `locked` tinyint(4) NOT NULL default '0', PRIMARY KEY (`topic_id`) ) TYPE=MyISAM Already Done
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_version', '2.0 Beta') OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_title', 'Coppermine Simple Forum') OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_guest_browse', 1) OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_guest_post', 1) OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_hot_topic_msg', 20) OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_topic_per_page', 20) OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_msg_max_size', 512) OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_msg_per_page', 15) OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_max_word_length', 30) OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_gap_time', 30) OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_avatar_size', 100) OK
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_signature_max_size', 512) OK
ALTER TABLE `cpg15x_users` ADD `fr_avatar` varchar(255) NOT NULL DEFAULT '' OK
ALTER TABLE `cpg15x_users` ADD `fr_signature` text NOT NULL DEFAULT '' OK
Performing database updates
UPDATE `cpg15x_config` SET value='2.1/Beta/9' where name='fr_version' OK
CREATE TABLE IF NOT EXISTS `cpg15x_fr_notify` ( `user_id` int(10) NOT NULL default '0', `topic_id` mediumint(8) NOT NULL default '0', `board_id` smallint(5) NOT NULL default '0', `send` tinyint(1) NOT NULL default '0' ) TYPE=MyISAM Already Done
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_time_online_checking', 5) OK
CREATE TABLE IF NOT EXISTS `cpg15x_fr_badwords` ( `word_id` int(10) NOT NULL auto_increment, `word` varchar(45) NOT NULL default '', `replace` varchar(45) NOT NULL default '', PRIMARY KEY (`word_id`) ) TYPE=MyISAM Already Done
INSERT INTO `cpg15x_config` (name, value) VALUES ('fr_msg_icons', 1) OK
ALTER TABLE `cpg15x_fr_messages` ALTER `icon` SET DEFAULT '1' Already Done
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 722
    • GMC Design Photo Gallery
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #126 on: January 21, 2014, 04:15:05 am »

The message log indicates 'already done' for the create table statements... I would have expected 'OK' since the statement is coded 'IF NOT EXISTS'. If the tables don't exist, make sure the user specified in includes/config.inc.php has 'CREATE TABLE' privileges in MySQL..
It should if you used the same user when you installed CPG??
In shared hosting, it is typically specified in cPanel or equivalent.

If that is ok, try executing one of the CREATE statements from a tool like phpMyAdmin... And see if you get an error.
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #127 on: January 21, 2014, 09:29:42 am »

I just tried to install the forum and it also doesn't create the tables. It works as expected if I remove
Code: [Select]
TYPE=MyISAMfrom the files in the sql/ folder.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #128 on: January 21, 2014, 09:55:57 am »

cpg1.5.x_plugin_cpgforum_v2.1-beta10.zip attached to initial post. It fixes the latest issue and also contain some other improvements.
Logged

computel

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #129 on: January 22, 2014, 08:37:18 am »

Thanks it worked.
Logged

sphoto

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 3
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #130 on: February 13, 2014, 03:16:39 am »

I downloaded the forum from the top link on 2/12/14. According to the plugin manager it is version 2.1 Beta. My coppermine version is 1.5.24. PHP version is 5.3.24 and MYSQL version is 5.6.

When trying to make a post in a board on my site I am getting the following error. Wondering if anyone has any ideas.

Array (
  • => Error Number: 1364 [1] => Field 'poster_email' doesn't have a default value [2] => INSERT INTO cpg15x_fr_messages (icon, subject, body, poster_time, poster_id, poster_name, poster_ip, smileys_enabled, topic_id, board_id)
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 722
    • GMC Design Photo Gallery
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #131 on: February 13, 2014, 03:24:39 am »

Bridged with phpBB3 by chance?
Try this link if so:  https://www.phpbb.com/kb/article/doesnt-have-a-default-value-errors/.
I recently had to use this technique with a phpBB3 installation at 3.0.7. Worked very well.
Or is this a plugin table?
Problem seems same (and maybe same cause) - but may need a different solution...
« Last Edit: February 13, 2014, 03:30:51 am by gmc »
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

sphoto

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 3
Re: Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #132 on: February 13, 2014, 03:30:48 am »

Bridged with phpBB3 by chance?

No bridge... completely standalone.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #133 on: February 13, 2014, 10:59:35 am »

Have you tried to post as guest or registered user?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #134 on: February 13, 2014, 11:08:12 am »

Have you tried to post as guest or registered user?

It seems that this doesn't matter. Please set a default value for the database field poster_email (with a tool like phpMyAdmin). If don't know how or haven't any posts in your forum yet, we also could re-install the forum plugin with an updated SQL file.
Logged

sphoto

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 3
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #135 on: February 13, 2014, 04:46:56 pm »

Thanks André. I'll try that later today and get back to you. Could it be happening due to me not having email set up on my server in PHP? I tried posting as a registered user. Tried selecting notification on and off. This is a brand new install of Coppermine and the Forum.

If I can't get this to work, is there a private message plugin that works well? I don't need the functionallity of a forum, I just need a messenger.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine forum plugin (cpgforum) for cpg1.5.x
« Reply #136 on: February 13, 2014, 05:02:50 pm »

There's a private messaging plugin, but your forum issue is very easy to fix.
Logged
Pages: 1 ... 3 4 5 6 [7]   Go Up
 

Page created in 0.021 seconds with 21 queries.