Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Invalid]: Redirect Not Working After Logon - phpbb3 and cpg  (Read 5868 times)

0 Members and 1 Guest are viewing this topic.

BigRed

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
[Invalid]: Redirect Not Working After Logon - phpbb3 and cpg
« on: April 23, 2010, 09:43:47 pm »

0I have the following issue when trying to bridge coppermine and phpbb3:
[error message here]

Coppermine install: http://www.lsrcc.com/gallery/
Forum install: http://www.lsrcc.com/portal/
Coppermine version: cpg1.4.26
Forum version: phpbb3 3.0.7-PL1
Test user account: test / testtest
BridgeManager settings:
// define the var array
$default_bridge_data['phpbb3'] = array(
  'full_name' => 'phpBB version 3',
  'short_name' => 'phpbb3',
  'support_url' => 'http://www.phpbb.com/',
  'full_forum_url_default' => 'http://www.lsrcc.com/portal',
  'full_forum_url_used' => 'http://www.lsrcc.com/portal',
  'relative_path_to_config_file_default' => '../portal/',
  'relative_path_to_config_file_used' => '../portal/',
  'use_post_based_groups_default' => '0',
  'use_post_based_groups_used' => 'radio,1,0',
   'cookie_prefix_default' => 'phpbb3_82eot',
   'cookie_prefix_used' => 'phpbb3_82eot',



I'm having issues after logging in through cpg not getting re-directed back to cpg, it just goes to the board index. I did try altering the ucp.php (http://forum.coppermine-gallery.net/index.php/topic,53678.0.html) without any success. I'm sure its my inexperience and lack of knowledge and I bet its going to be something simple.
« Last Edit: April 24, 2010, 01:18:22 pm by Joachim Müller »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Redirect Not Working After Logon - phpbb3 and cpg
« Reply #1 on: April 24, 2010, 01:18:13 pm »

Redirection after login is a feature in some bridging apps. In others, it's not a feature. Anyway, this is something you need to change in your bridging app, not in Coppermine. We're not familiar with your bridging app. That's why you need to ask this somewhere where the people who know your bridging app (phpbb3 in your case) are. We're not familiar with your bridging app and therefore can't help you. Marking thread accordingly.
Logged

BigRed

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
Re: Redirect Not Working After Logon - phpbb3 and cpg
« Reply #2 on: April 24, 2010, 05:34:34 pm »

Redirection after login is a feature in some bridging apps. In others, it's not a feature. Anyway, this is something you need to change in your bridging app, not in Coppermine. We're not familiar with your bridging app. That's why you need to ask this somewhere where the people who know your bridging app (phpbb3 in your case) are. We're not familiar with your bridging app and therefore can't help you. Marking thread accordingly.

I used the bridge app from this website, http://forum.coppermine-gallery.net/index.php/topic,53678.0.html
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4453
    • Windsurf.me
Re: [Invalid]: Redirect Not Working After Logon - phpbb3 and cpg
« Reply #3 on: April 24, 2010, 07:17:49 pm »

By bridging app we mean PHPBB3 in your case. Yes, we provide the bridge but all that does is hand over user control to the third party app (PHPBB3). As many of us do not use that app we cannot really offer any help. If you go over to the PHPBB forums a quick search will tell you exactly what part of their code to modify and IIRC they even provide a .zip file that includes the modified files.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

BigRed

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
Re: [Invalid]: Redirect Not Working After Logon - phpbb3 and cpg
« Reply #4 on: April 24, 2010, 09:08:51 pm »

Gotcha, thanks.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 21 queries.