Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: eFiction + Commpermine Possible Permission Issues  (Read 9576 times)

0 Members and 1 Guest are viewing this topic.

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
eFiction + Commpermine Possible Permission Issues
« on: April 12, 2010, 04:28:04 pm »

I'm not actually sure if this issue is bridge related or not, but I'm thinking it must be because all levels of users were able to upload images before the bridge was installed. I had a friend help me get the eFiction/Coppermine bridge created for Calic0cat in 2006 working with eFiction 3.5.2, but now, no matter what I change in the group permissions or album permissions, there is no upload files link. No users, not even myself logged in as Admin are able to upload files because no link comes up. I am new to coppermine, but I've checked album and group permissions a million times and they appear to be set properly from what I've read here on the forum and in the Documentation, so I don't understand what's wrong. It's quite possible that I might be overlooking something simple, but after 6 hours of messing with it, I can't figure out what. If Admin accesss is needed, I can provide this privately as well.

Please note, there is no link from the eFiction archive to the Coppermine gallery yet because I don't want my members to have access to the gallery until I can figure out the problem.

Thank you in advance.

Coppermine install: http://www.forbiddenarchive.com/gallery/
Efiction install: http://www.forbiddenarchive.com/
Coppermine version: cpg1.4.26
eFiction version: eFiction 3.5.2
Test user account: Test / test123

BridgeManager settings:
Forum URL:  http://www.forbiddenarchive.com/
Relative path to your BBS's config file:  ../forbiddenarchive.com/
Use post-based groups?:  0
Cookie name/preifx (if applicable): N/A
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: eFiction + Commpermine Possible Permission Issues
« Reply #1 on: April 12, 2010, 05:23:49 pm »

The login doesn't stick from your bridging app to coppermine, so from the perspective of coppermine you're not logged in, but just a guest. Subsequently, you don't have upload permissions (because that's how you obviously set your gallery up). I'm not familiar with the app you bridge with, but to me it seems as if that app is using session authentification, which is something coppermine doesn't work with. You need to enable cookie based authentification in your bridging app. Can't help you with that, as I'm not familiar with eFiction. Your best bet is to ask the guy who modded the bridge file for you.

Joachim
Logged

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: eFiction + Commpermine Possible Permission Issues
« Reply #2 on: April 12, 2010, 05:36:18 pm »

Thank you for the quick reply. Even when I set it so guests can upload files, there is still no upload link. I realize that's not a solution, but I did test that out to see if it was related. Unfortunately I don't know half as much as I should about cookies and session authentication, so I will look into it and see what I can find out. It's unfortunate that I can't find support for this bridge anywhere, but I guess it's just that old.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: eFiction + Commpermine Possible Permission Issues
« Reply #3 on: April 12, 2010, 05:39:26 pm »

Even when I set it so guests can upload files, there is still no upload link
How do you do that if you can't log in as admin?

I realize that's not a solution, but I did test that out to see if it was related.
You're doctoring the symtoms. Cure the cause instead
Unfortunately I don't know half as much as I should about cookies and session authentication, so I will look into it and see what I can find out. It's unfortunate that I can't find support for this bridge anywhere, but I guess it's just that old.
I rather guess that eFiction is not used that often. Ask on the eFiction community support if that app can be toggled between cookie-driven authentification and session-based authentification.
Logged

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: eFiction + Commpermine Possible Permission Issues
« Reply #4 on: April 12, 2010, 05:42:56 pm »

Quote
How do you do that if you can't log in as admin?

I can log in as Admin and as a regular user as well. I just can't upload anything.

Quote
Ask on the eFiction community support if that app can be toggled between cookie-driven authentification and session-based authentification.

I'll see what I can find out over there. Thanks again.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: eFiction + Commpermine Possible Permission Issues
« Reply #5 on: April 12, 2010, 06:04:44 pm »

I can log in as Admin and as a regular user as well. I just can't upload anything.
You're not getting the point: you can log in into eFiction. That's what I can do as well using the non-admin test user account that you posted above. But that login doesn't stick in your Coppermine-driven gallery. As far as Coppermine is concerned, you're not logged in. You can easily see that this is the case: after loggin in into your eFiction page and the going to your gallery the login link is still there, and the logout link is not there. Those are indicators for what I said. If this is otherwise for you, post a screenshot of your gallery after having logged in successfully.
Logged

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: eFiction + Commpermine Possible Permission Issues
« Reply #6 on: April 12, 2010, 06:11:20 pm »

I've logged into both the Test account I listed in my main post and the Admin account. I've uploaded screenshots of both. I'm not sure why this is different for me than it is for you.
Logged

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: eFiction + Commpermine Possible Permission Issues
« Reply #7 on: April 21, 2010, 12:19:01 pm »

Does anyone have any idea as to what might be causing this? I'm still able to log in as admin or as a regular member as I've demonstrated in the screen shots, but there is still no upload link no matter what I do to the permissions. I am completely stuck and unable to ope the gallery section of my site to my members until I work this out. I'm happy to give the admin password if it's needed. Thanks in advance.
Logged

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: eFiction + Commpermine Possible Permission Issues
« Reply #8 on: April 21, 2010, 12:23:40 pm »

My apologies. I tried to delete my post to fix the typo and didn't realise that was not possble. Problem is still outstanding. Sorry about that.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: eFiction + Commpermine Possible Permission Issues
« Reply #9 on: April 21, 2010, 02:44:46 pm »

Problem remains the same for me using the test user account you posted no matter what you say. Subsequently, there is no upload permission, as the login doesn't stick in the first place. Prove to me that loging in with the test user accounts works and that it sticks.
Logged

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: eFiction + Commpermine Possible Permission Issues
« Reply #10 on: April 21, 2010, 04:12:15 pm »

I'm not sure how else to prove that I can log in and stay logged in aside from the screen shots I already uploaded which show the admin control panel and the log out option as both Test and Admin. Would you like to try with the admin account? I could have someone else log in and take screen shots as well, but they would look the same as what I've already uploaded. I've logged in as Admin and changed the name of the gallery. Does that prove that I can both log in and stay logged in? I can't change anything or post comments in the test account to prove that I am indeed logged in because I am still unable to upload an image to comment on.
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1498
  • aka 'i-imagine'
    • Home Page
Re: eFiction + Commpermine Possible Permission Issues
« Reply #11 on: April 21, 2010, 06:08:32 pm »

Joachim is correct.
Logging in to http://www.forbiddenarchive.com/ and then opening http://www.forbiddenarchive.com/gallery/  in a new browser tab clearly shows the user is not logged.

You should repeat your tests starting with all of your cookies/cache/etc cleared and empty.
Then:
1) Log in 
2) Open the gallery in a new browser tab/window
3) You will see that Coppermine has the button/field "login" displayed. That means Coppermine does not have you logged in.

I tried it twice.....

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: eFiction + Commpermine Possible Permission Issues
« Reply #12 on: April 21, 2010, 07:20:48 pm »

Thank you for taking the time to look into this as well. I've cleared my cookies/cache several times over the past week that I've been trying to figure out why there is no upload files link and the results for me are still the same. I've tried a handful of different browswers as well. I am definitely logged into Coppermine because I can change things in the admin control panel and see the log out link as well. I wouldn't be able to do this if I were not logged in to the gallery, correct? I'm just not sure why this is different for you and Joachim. I wish I knew what to suggest so you could see the same thing I'm seeing.
Logged

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: eFiction + Commpermine Possible Permission Issues
« Reply #13 on: April 21, 2010, 07:30:08 pm »

To make sure I'm not going nuts, I just went upstairs and used my laptop and a second laptop as well and was still able to log into both the Test and Admin accounts. The log out field and the Admin controls are all showing up fine. I'm completely lost as to why no one else can see this.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: eFiction + Commpermine Possible Permission Issues
« Reply #14 on: April 21, 2010, 08:04:58 pm »

When clicking on the login link in Coppermine I get sent to http://forbiddenarchive.com//user.php?action=login (notice the double slash!), which is an indicator that there is something wrong with your bridging.

Both on IE8.0.6001 as well as on Firefox3.6.3 on Windows XP Prof German SP3 the login doesn't stick for me. However, in Firefox3.5.9 on Ubuntu 9.10, the login DOES stick for me as well. Both machines sit behind the same firewall/router. So we're getting somewhere.
Logged

Jaded1

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: eFiction + Commpermine Possible Permission Issues
« Reply #15 on: April 21, 2010, 08:12:51 pm »

I did notice the double slash, but I wasn't sure what it meant. Any idea what might be causing it?

Once again, I do very much appreciate you taking the time to look into this for me.
Logged

skinheaddave

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: eFiction + Commpermine Possible Permission Issues
« Reply #16 on: April 21, 2010, 08:53:42 pm »

Dave here.

I am helping Jaded with this issue.   I have gone and fixed the double-slash thing.  There was trailing slash after the site url but then no leading slash in front of the profile link.  This is all in the bridge configuration.  Anyhow, that should be fixed?

With respect to logging in, I've been trying it in firefox and everything is kosher.  It has been logging in and sticking etc. but I still can't add galleries.  I added a bit of script to echo the cookie information (access /gallery?test=true) but am unsure of the nature of the ID field and so am not sure as to how to go about testing whether it is good or not.

It would seem as if the bridge, by virtue of having url information in its configuration, works its way into the menu system.  So then it may be possible to be logged in but not recognized as such by the core coppermine code? 

Cheers,
Dave
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1498
  • aka 'i-imagine'
    • Home Page
Re: eFiction + Commpermine Possible Permission Issues
« Reply #17 on: April 21, 2010, 09:32:44 pm »

With respect to logging in, I've been trying it in firefox and everything is kosher. 

What Joachim has written still applies......

Both on IE8.0.6001 as well as on Firefox3.6.3 on Windows XP Prof German SP3 the login doesn't stick for me.

It does not stick for me using IE8 or Opera 10.51.

You might want to turn on debug to see what Coppermine is thinking...(please don't post the output)
The eFiction site did not have promising statements about bridging with an established site - perhaps try checking further there too.

skinheaddave

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: eFiction + Commpermine Possible Permission Issues
« Reply #18 on: April 21, 2010, 10:09:23 pm »

What Joachim has written still applies......
Yes, I realize that.  There is more at play here than just browsers, though.  Using the same browsers (IE 8.0.6001 and FF 3.6.3) on the same system (XP Pro SP3 .. though not German) I am getting it to stick.  You don't get it to stick in two browsers.  He gets it to stick in some but not others.   

Quote
You might want to turn on debug to see what Coppermine is thinking...
Will do.

Cheers,
Dave
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: eFiction + Commpermine Possible Permission Issues
« Reply #19 on: April 22, 2010, 08:04:28 am »

The issues are related to your usage of the www subdomain. You said in above posting that the URL of your gallery was http://www.forbiddenarchive.com/gallery/, but you're actually accessing http://forbiddenarchive.com/gallery/. In that setup, the login does stick. Do as suggested in http://documentation.coppermine-gallery.net/en/bridging.htm#integrating_subdomain_www
Logged
Pages: [1]   Go Up
 

Page created in 0.035 seconds with 21 queries.