Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [1.5][Bug] Registered Users can't create albums  (Read 9129 times)

0 Members and 1 Guest are viewing this topic.

Alu

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
[1.5][Bug] Registered Users can't create albums
« on: February 06, 2010, 02:29:01 am »

We just changed from coppermine 1.4 to 1.5 and noticed a new problem with JUpload:

While registered Users can create albums manually, they cant do it in JUpload.
And if they create an album outside of JUpload, they can't see it in JUpload.

I think the problem is, when they create an album, the album is still set to "users can upload files - (no)"
With normal file upload the album creator is still able to add pictures to the album, while JUpload doesnt show the album in the selection.
Logged

papukaija

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 333
Re: [1.5][Bug] Registered Users can't create albums
« Reply #1 on: February 06, 2010, 10:39:17 am »

Quote
The cpg1.5.x series is currently still in beta stage and goes completely unsupported (that's why there is no button on the cpg1.5.x support board that enables you to start a new thread - only the support forum has been created in advance to have a structure to refer to from within the documentation). Unsupported means: you're not allowed to ask a question about cpg1.5.x at all.
(from Public release of cpg1.5.2 (beta) )
Logged

Alu

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: [1.5][Bug] Registered Users can't create albums
« Reply #2 on: February 07, 2010, 09:14:10 pm »

(from Public release of cpg1.5.2 (beta) )

so what? I do not want support, I just wanted to report this bug. Or isn't this allowed either?
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4454
    • Windsurf.me
Re: [1.5][Bug] Registered Users can't create albums
« Reply #3 on: February 07, 2010, 09:44:49 pm »

Of course it is allowed but please file a bug report as outlined here. Just to give the author more info to go on.

http://documentation.coppermine-gallery.net/en/testing.htm
« Last Edit: February 07, 2010, 10:31:07 pm by Phill Luckhurst »
Logged
It is a mistake to think you can solve any major problems just with potatoes.

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: [1.5][Bug] Registered Users can't create albums
« Reply #4 on: February 07, 2010, 10:24:26 pm »

Hi,

  My understanding is that this is a bug relative to JUpload.

So, thanks to Alu,I'll have the opportunity to correct this one.

Actually, I've added this to my todo list. I'm building a new release of the applet, and adding a lot of unit testing. I guess this correction is not urgent, and is more a report so that I'm aware of it.


It's Ok for me.


Regards
Etienne
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: [1.5][Bug] Registered Users can't create albums
« Reply #5 on: February 18, 2010, 10:51:07 am »

Here are some more informations.

1. If you create an album in the user gallery with JUpload, you can upload pictures with JUpload. Standard upload is also possible with that album, but it breaks after the redirect to editpics.php. Additionally the album won't be displayed under 'My gallery'.
-> Reason: in the pictures table the owner is set wrong (in my case the user has id 4, but in the database is inserted 1). That column was added in cpg1.5.x.

2. If you create an album in the user gallery with Coppermine, you can upload pictures with JUpload.
-> Okay.

3. Since cpg1.5.x it's possible that regular users create albums in the public gallery. JUpload doesn't display them in the category select box.
-> Result: It's not possible to create a public album and it's not possible to select a public album which has been created with the Coppermine album manager.
-> Reason: in cpg1.5.x there is a new table categorymap, which JUpload disregards (I haven't checked the code, but I think that's the reason). In that table are stored the permissions for public categories.


Regards
André
Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: [1.5][Bug] Registered Users can't create albums
« Reply #6 on: February 18, 2010, 11:51:32 am »

Excellent !

  Thanks for this analysis, André.    :)


  You're puttin pressure on me (hum, French expression, I guess you know it ...). I'll have to solve this one quickly. I have a running on task, for the applet alone.
  I finish this taks, and I'll then switch to this correction...

Etienne
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: [1.5][Bug] Registered Users can't create albums
« Reply #7 on: June 11, 2010, 12:23:12 pm »

Any news Etienne?
Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: [1.5][Bug] Registered Users can't create albums
« Reply #8 on: June 12, 2010, 10:28:18 am »

Hi,

  You're right to 'awake' me here.

I'm fighting with compilation detail for the applet, and I'm tired there..


  Ok, I'll take a temporary (but valid) and release a new version for the Coppermine plugin quickly.

Etienne
Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: [1.5][Bug] Registered Users can't create albums
« Reply #9 on: June 24, 2010, 12:19:40 am »

Hi,

  These one were quite heavy to manage. Lots of impact.

Now solved, out of one: creation of album in the 'no category' category doesn't work.


Please check the 4.1.0.

Etienne
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: [1.5][Bug] Registered Users can't create albums
« Reply #10 on: June 24, 2010, 07:43:33 am »

Hi Etienne,

looks good so far. Will perform some thorough tests later (hopefully today).


Good work!
Logged
Pages: [1]   Go Up
 

Page created in 0.063 seconds with 20 queries.