Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Déconnection lors de l'édition de descriptions d'images  (Read 2045 times)

0 Members and 1 Guest are viewing this topic.

colinou

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Déconnection lors de l'édition de descriptions d'images
« on: January 16, 2010, 04:48:31 pm »

Bonjour,

Je maintiens une gallerie coppermine depuis plusieurs années sur free.fr sans problèmes. Je viens de migrer la gallerie sur sfr.fr. Après un peu de travail, la voilà en place à l'identique (http://colinou.richard.perso.sfr.fr/coppermine/index.php).

Je me suis rendu compte du problème lors de la création d'un nouvel album (sur le nouveau serveur donc), même si après avoir manipé il est présent sur tous les albums, y compris ceux crées sur l'ancien serveur donc:

1. Je me logge en tant qu'admin
2. je clique sur "modifier les photos" d'un album
3. les images s'affichent avec les différents champs à remplir
4. je clique sur "appliquer les modifs". Le message coppermine "Vous n'avez pas la permission d'accéder à cette page." s'affiche. Je ne suis plus loggé en tant qu'admin.
4bis. Après pas mal de manips, je me rends compte que ce problème n'apparait que si j'essaye d'éditer plus de 21 (précisément) descriptions d'images. Par exemple, si je modifie les descriptions d'un album de 10 photos, tout se passe commé prévu. Plus compliqué; j'édite un album de 30 photos, les 25 premières photos s'affichent; je clique sur "appliquer", message d'erreur ci dessus. Par contre si je clique sur "Voir les images suivantes", les 5 photos suivantes s'affichent. Comme il y en a moins de 21, je peux modifier celles ci!

Par ailleurs, je peux modifier les descriptions de manières individuelles dans les albums sans problèmes.

J'ai du mal à comprendre l'origine du problème. Dans PHPAdmin, je ne vois aucune différences entre la base de données sur free.fr et celle sur sfr.fr. J'ai bien vérifié que le problème n'est pas présent sur la copie de ma gallerie sur free.fr. J'ai par ailleurs testé le fonctionnement sous 2 navigateurs différents: le problème est identique.

Merci de vos idées...

Nr
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: Déconnection lors de l'édition de descriptions d'images
« Reply #1 on: January 16, 2010, 05:03:31 pm »

Bonjour,

première chose, mettez votre galerie à jour (version 1.4.12) alors que la dernière version stable de Coppermine est 1.4.25. Vous prenez de très gros risques de piratage en gardant une aussi ancienne version.
La mise à jour résoudra peut être le problème (la documentation n'est pas présente sur le serveur je ne sais pas si c'est intentionnel, mais si ce n'est pas le cas, il peut aussi manquer d'autres fichiers)
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 21 queries.