Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problem upgrading from 1.4.19 to 1.4.25  (Read 5639 times)

0 Members and 1 Guest are viewing this topic.

josec

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Problem upgrading from 1.4.19 to 1.4.25
« on: December 19, 2009, 06:12:12 pm »

I get the following error when upgrading to 1.4.25 from 1.4.19:

Fatal error: require_once() [function.require]: Failed opening required 'bridge/phpbb3.inc.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home7/manaboco/public_html/photo/include/init.inc.php on line 257

Other info: phpBB version:3.0.4
Website: http://www.manaboconnexion.com/photo

Thank you in advance for your help.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4456
    • Windsurf.me
Re: Problem upgrading from 1.4.19 to 1.4.25
« Reply #1 on: December 19, 2009, 06:17:55 pm »

Undo bridging (as per the docs) and your gallery shoul spring back to life. You'll then have to re-install your bridge before re-enabling.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Problem upgrading from 1.4.19 to 1.4.25
« Reply #2 on: December 20, 2009, 08:32:22 pm »

the phpbb3 bridge is not part of the coppermine package, so it can't have been replaced or removed if you have followed the upgrade instructions. As you got that error message, you obviously haven't followed the upgrade instructions. Restore the missing file that the error message complains about and you should be good even without doing as Phill suggested.
Logged

nikki4

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Problem upgrading from 1.4.19 to 1.4.25
« Reply #3 on: December 24, 2009, 11:13:08 am »

Hi, I have a problem with updating from 1.4.19 to 1.4.25 too.
I make a backup of the database, config.inc.php and anycontent.php.
then run http://mysite/gallery/update.php
Then i see the table with results of the update (which SQL requests  have already been done and new updates with green OK)
Then i check the version.. and it shows me 1.4.19.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Problem upgrading from 1.4.19 to 1.4.25
« Reply #4 on: December 24, 2009, 11:30:51 am »

Then you haven't replaced the files properly. Make sure that your FTP app is configured to overwrite existing files. If that doesn't solve your issue, start a thread of your own instead of hijacking someone else's thread.
Do exactly as suggested per board rules there and post a real link to your site and not just a dummy placeholder. You have broken nearly every rule there is, so you better read the rules carefully before you post again. Thanks.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 22 queries.