Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: update  (Read 14362 times)

0 Members and 1 Guest are viewing this topic.

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
update
« on: December 12, 2009, 03:18:04 pm »

hi all,

i have an older version of coppermine 1.3.2
how do i upgrade this to 1.4.x ?

just download> upload to my server > install ?

and another problem where i struggle whit the last 3 day's is.
where can i change the background color for the thumbs ?
Logged
 *Link Removed*

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: update
« Reply #1 on: December 12, 2009, 03:25:15 pm »

Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #2 on: December 12, 2009, 04:11:17 pm »

sorry my bad
Logged
 *Link Removed*

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #3 on: December 13, 2009, 08:40:13 am »

getting lots of errors traying to update from 1.3.x to 1.4.x so im putting back my backup of 1.3.x  :-\
Logged
 *Link Removed*

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: update
« Reply #4 on: December 13, 2009, 10:10:13 am »

what kind of errors ?
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #5 on: December 13, 2009, 04:59:47 pm »

euh dident right it down.
some  mysql and missing php and errors on line stuff.

Logged
 *Link Removed*

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: update
« Reply #6 on: December 13, 2009, 05:35:56 pm »

did you follow exactly the upgrading process ?
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #7 on: December 13, 2009, 06:24:55 pm »

i followd the instructions step by step
Logged
 *Link Removed*

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #8 on: December 13, 2009, 09:55:00 pm »

and if i copy the albums, deinstal coppermine 1.3.x, remove all files from my server, upload most resent stable version and install as if it was the first time and replase the old albums in the directory ?

could that work out ?
Logged
 *Link Removed*

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: update
« Reply #9 on: December 13, 2009, 10:06:04 pm »

No, you musn't do so, this way you will lost all database content.
Try this:
-backup your albums and custom theme folders and your config.inc.php, anycontent.php file on your computer
-erase all files from your server
-upload all the new cpg1.4.25 files on your server with a ftp client like filezilla
-replace the server Albums directory with the albums directory you backed up before (the old one)
-Upload the old config.inc.php and anycontent.php files and be sure to replace the existing files
-run the update.php script

This should do the trick.

Warning: do a database backup before...
if you had a custom theme, you must update them to (look into the doc). before, to make sure all is ok, and before starting the upgrade process, make the classic theme as default theme
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #10 on: December 13, 2009, 11:11:36 pm »

well that is i think one of the problems i hade.
i dont have a config.ini.php, i have only the config.php.

i already trayd what you sayd but also errors, i think couse i don't have those ...ini.php files.
i also trayd to edit the files so the update looks for the config whitout the .ini.
but that messed everthing up  :o
Logged
 *Link Removed*

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: update
« Reply #11 on: December 14, 2009, 07:22:27 am »

look into the incluse folder. This file should be there. If not, edit the config.inc.sample.php file, rename it in config.inc.php and put in the correct database connection datas
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #12 on: December 14, 2009, 09:14:15 am »

oke ill try agian
Logged
 *Link Removed*

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #13 on: December 14, 2009, 09:25:15 am »

this is what i get :

Warning: main(include/config.php) [function.main]: failed to open stream: No such file or directory in C:\domains\gs4r.com\wwwroot\modules\coppermine\update.php on line 25

Warning: main(include/config.php) [function.main]: failed to open stream: No such file or directory in C:\domains\gs4r.com\wwwroot\modules\coppermine\update.php on line 25

Warning: main(include/config.php) [function.main]: failed to open stream: No such file or directory in C:\domains\gs4r.com\wwwroot\modules\coppermine\update.php on line 25

Fatal error: main() [function.require]: Failed opening required 'include/config.php' (include_path='.;C:\PHP4\pear') in C:\domains\gs4r.com\wwwroot\modules\coppermine\update.php on line 25

if i look at line 25 in the update.php :

require ('include/sql_parse.php');
require ('include/config.php');
require ('include/update.php');

but when i look at my old version of coppermine. ther is no config in the map include  :-\
it is in te map coppermin itself
Logged
 *Link Removed*

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: update
« Reply #14 on: December 14, 2009, 09:31:36 am »

are you sure to have overwrite all old files except the albums folder, the custom theme and the config.inc.php and anycontent.php files with the cpg1.4.25 files ? (sorry to ask this once angain, but it's often not the case...)
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #15 on: December 14, 2009, 09:43:13 am »

no worry's betther dubble chek  ;)

the albums map i deleted from the update so i cant overright them.

the config.ini.php i dont have in the older version, so that one cant be overright

the new anycontend.php i renamed whit 123anycontend.php so that one cant overright

i dubbel chekt that all files are uploaded.

in the line 25 of the update.php he is looking for the config.php and there is only the config.ini.php.

i trayd to edit it to require ('config.php');
but that dident work

i trayd to edit the config.ini.php to config.php
but that diddent work
Logged
 *Link Removed*

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #16 on: December 14, 2009, 09:50:37 am »

shall i try to make a copy of the config file thats lokated in the coppermine map and past it in the include map ?
Logged
 *Link Removed*

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: update
« Reply #17 on: December 14, 2009, 10:11:30 am »

i have send you a PM
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

noja

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • G S 4 R Designs
Re: update
« Reply #18 on: December 14, 2009, 10:18:40 am »

mail on his way
Logged
 *Link Removed*

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: update
« Reply #19 on: December 14, 2009, 10:26:49 am »

The URL http://gs4r.com/modules.php?name=coppermine suggests that you appear to have been using a sort of "module" of some CMS (obviously PHP nuke), which goes unsupported (as in "no support at all"). You have not being using cpg1.3.x, at least not a version that we provide or support. We do not support nuke, as suggested countless times.
Logged
Pages: [1] 2   Go Up
 

Page created in 0.019 seconds with 21 queries.