Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 [3] 4 5 6 7 ... 9   Go Down

Author Topic: Flash Media Player plugin with visual integration (play flv/mp4/mp3/aac files)  (Read 136404 times)

0 Members and 1 Guest are viewing this topic.

lhansson

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

Thanks for the hint.I see the difference  :)
but the second link doesn't work as I don't have any 15x folder. The story is that I reused the 14x folder when upgrading to 15x as I had many links out pointing on the albums. So all the pictures are in 14x/albums and that is working even that the link actually says 15x/albums there as well. Apparently the plugin for mp4 (in my case) looks at the full URL and the pictures only at a relative URL.
I've just tested to add the file into a new 15x/albums folder and now I got sound, but no picture...
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369

the second link doesn't work as I don't have any 15x folder
I know. You have to enter the correct path for that setting.
Quote
It is absolutely mandatory that you enter the gallery URL setting properly - if you don't, you will almost certainly experience "funny" behaviours of your gallery.


I've just tested to add the file into a new 15x/albums folder and now I got sound, but no picture...
Please undo.
Logged

commonplace

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

Hi Αndré, when you have a moment, could you take a look at an MP4 video I uploaded and see if you can give me any hints as to why it won't show the video? It plays just the audio.

My gallery is here:  http://photos.envail.com/

This is the specific video:  http://photos.envail.com/displayimage.php?album=16&pid=324

If you need any more information or anything from me, please let me know -- I read all the rules before posting and think/hope I've followed all of them!

Thank you so much,
Kevin
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369

Hi Kevin, please upgrade to cpg1.5.8 and disable all other plugins for testing purposes.
Logged

commonplace

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

Thanks Αndré! I upgraded to 1.5.8 and uninstalled all of the plugins except this one (flash_media_player), and it still does the same thing; sound, but no video. Let me know what you'd like me to try next. Thanks again!

/Kevin
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369

Please try another mp4 file and make sure if it's really encoded in mp4. Maybe the current video codec is not supported by the player, as the file is no mp4 video but has that file extension.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369

Your file doesn't work on my testbed, too, but other files work.
Logged

commonplace

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

You're right, Αndré, it's the video itself. Darn! That's the video format my Palm Pre smartphone creates its videos in, but apparently it's not doing H.264 encoding so it won't play back in Flash, period. So, there's nothing you or anyone else can do. Thanks so much for your help!

/Kevin
Logged

ShiversOfHorror

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Female
  • Posts: 60

I'm trying to figure out where to change the default size of my FLV videos. I came across this post, and attempted #2. I added that code to the bottom, switching out the size I needed, but it did not work.

Just change the Coppermine setting accordingly.

You have two possibilities:
1.) Change the dimensions in the 'edit file' form (edit_one_pic.php)
2.) Set the default aspect ratio in codebase.php. Add something like
Code: [Select]
if ($CURRENT_PIC_DATA['pwidth']==0 || $CURRENT_PIC_DATA['pheight']==0) {
    $CURRENT_PIC_DATA['pwidth'] = 640;
    $CURRENT_PIC_DATA['pheight'] = 360;
}

I don't know if I understand the first option well. So from looking at the following line of code:

Code: [Select]
            <object type="{$CURRENT_PIC_DATA['mime']}" width="{$CURRENT_PIC_DATA['pwidth']}" height="{$CURRENT_PIC_DATA['pheight']}" data="$player">
I tried to find where $CURRENT_PIC_DATA was in the edit_one_pic.php, but I couldn't find the different types of them - like displayed above in my code box.

I thought with the original edits for 1.4.x it was in theme.php. But after looking at everything I think I'm just confusing myself more. I need my videos to default to 512x384.

It's a good idea to upload thumbnails for your audio/video files with the Custom Thumbnail plugin.

Does that mean we cannot do the "thumb_videonamehere.jpg" method anymore?

I am switching from 1.4.x to 1.5.8 and I have tons of videos that are uploaded by this method, is that going to be a problem after the upgrade?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369

I don't know if I understand the first option well. So from looking at the following line of code:
Use the button below your picture. No code modifications needed.


Does that mean we cannot do the "thumb_videonamehere.jpg" method anymore?
Of course you can use that method. That plugin just helps you to upload custom thumbnails, especially when you or your users upload files via http.


Logged

ShiversOfHorror

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Female
  • Posts: 60

Use the button below your picture. No code modifications needed.

Of course you can use that method. That plugin just helps you to upload custom thumbnails, especially when you or your users upload files via http.


I know I can fill in the specific size for each video, but there must be some way to code it into it so I don't have to edit each one right?

Also, I uploaded both video and thumbnail like on 1.4.x and it didn't work for me, and I realized its probably because somehow one extra character got into the thumbnail name lol.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369

Open codebase.php, find
Code: [Select]
$CURRENT_PIC_DATA['pheight'] += 24;and replace with
Code: [Select]
    $CURRENT_PIC_DATA['pwidth'] = 512;
    $CURRENT_PIC_DATA['pheight'] = 384;
    $CURRENT_PIC_DATA['pheight'] += 24;
Logged

ShiversOfHorror

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Female
  • Posts: 60

Thank you Αndré, that worked like a charm.
Logged

electronico

  • Coppermine newbie
  • Offline Offline
  • Posts: 14

Hi all,

I have updated CPG to 1.5.8 and added this flash media player plugin.
I had written a script to make thumbnails from .FLV and upload them to CPG so I don't use the Thumbnail plugin.
All works OK except the bottom of the page where previous and next video thumbnails appear.
101011_coppermine_flv_1 shows the video album with the video thumbnails that are OK
101011_coppermine_flv_2 shows the video playing ans the strange looking thumbnails for previous/next videos

Thanks in advance for any track where I should look to.

PS : I would prefer not to post link to the gallery as it is a personal/family one, thanks for your comprehension.
Logged

electronico

  • Coppermine newbie
  • Offline Offline
  • Posts: 14

OK, please excuse-me to have posted prior to investigate further ...

It turns out that the script I wrote to make thumbnails from FLV was creating a file named thumb_my-flv-filename.jpg in original .flv format (640*480 in my case).
Looking at the others files thumb_*.jpg in CPG (from pictures), I see they are in 100*75 format.
That's why the 'film strip' had a so big height and was displaying strange thumbnails.

I have just updated my script to make :
normal_my-flv-filename.jpg in original .flv format
and a :
thumb_my-flv-filename.jpg in 100*75 format

Film Strip is now OK.

(This is probably what the Custom Thumbnail script do)

Hope this might help others.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369

This is probably what the Custom Thumbnail script do
Yes ;)

I have just updated my script to make :
normal_my-flv-filename.jpg
You don't need that file.
Logged

thaefliger

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

Hello

i just installed the Flash Media Player Plugin to play mp3-Files in a coppermine gallery.
the player doesn't load anything, no error message, no sound.
I tried it on different browsers/operating systems, it just diesn't work.

Can you please help me?
Link to gallery page: http://www.haefliger-ag.ch/churchplus/media/displayimage.php?album=55&pid=625#top_display_media

Thank you

tom
Logged

Nibbler

  • Guest

Check you have your gallery url set correctly in config. It seems to be pointing to a different domain.

Are the links at the bottom of your page intentional or were you hacked while running 1.5.6 ?
Logged

thaefliger

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

Thank you, in fact the Gallery-URL was wrong.

Which links do you mean?
Logged

Brooklyn

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33

Viewing the generated source of your posted link, the following is embedded at the bottom of the page:

Code: [Select]
<!-- [b2c5373fe15570b6ca12e74b9d321850 --><!-- 6070857821 --><noscript><ul><li><a href="http://www.[REMOVED].org/?motion=477">microsoft windows vista home basic product key</a></li><li><a href="http://www.[REMOVED].org/?motion=336">microsoft works download</a></li><li><a href="http://www.[REMOVED].org/?motion=992">download Adobe Illustrator CS4 MAC (Macintosh) software</a></li><li><a href="http://www.[REMOVED].org/?motion=295">buy Adobe Creative Suite 4 Design Premium MAC (Macintosh) license</a></li><li><a href="http://www.[REMOVED].org/?motion=384">windows xp professional sp3 32 bit free download</a></li><li><a href="http://www.[REMOVED].org/?motion=16">buy windows 7 home premium (64 bit) full version</a></li><li><a href="http://www.[REMOVED].org/?motion=127">microsoft works 9 update</a></li><li><a href="http://www.[REMOVED].org/?motion=134">buy discount Microsoft Office 2007 Standart</a></li><li><a href="http://www.[REMOVED].org/?motion=714">microsoft office templates</a></li><li><a href="http://www.[REMOVED].org/?motion=738">cyberlink powerdirector 8 ultra coupon</a></li><li><a href="http://www.[REMOVED].org/?motion=48">adobe indesign cs4 download</a></li><li><a href="http://www.[REMOVED].org/?motion=755">autodesk autocad 2010 crack</a></li><li><a href="http://www.[REMOVED].org/?motion=934">order Microsoft Office 2007 Enterprise software</a></li><li><a href="http://www.[REMOVED].org/?motion=342">adobe photoshop cs4 free download</a></li><li><a href="http://www.[REMOVED].org/?motion=231">Windows 7 Professional (32 bit) software purchasing</a></li><a href="http://www.[REMOVED].org/?motion=667">buy used Intuit Quicken Rental Property Manager 2009 inexpensive</a></li><li><a href="http://www.[REMOVED].org/?motion=275">buy microsoft office 2007 enterprise online</a></li><li><a href="http://www.[REMOVED].org/?motion=817">intuit quicken rental property</a></li><li><a href="http://www.[REMOVED].org/?motion=912">microsoft windows vista ultimate with sp2</a></li></ul></noscript><!-- b2c5373fe15570b6ca12e74b9d321850] -->
I removed the actual website domain and replaced with [REMOVED] so as not to assist the SEO results here. The above is only a small example of the 250 embedded spam links you have generated from your output.
Logged
Pages: 1 2 [3] 4 5 6 7 ... 9   Go Up
 

Page created in 0.038 seconds with 20 queries.