Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 3 4 [5]   Go Down

Author Topic: MiniCMS plugin for cpg1.5.x  (Read 48647 times)

0 Members and 1 Guest are viewing this topic.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Online Online
  • Posts: 670
Re: MiniCMS plugin for cpg1.5.x
« Reply #80 on: October 15, 2014, 03:22:35 am »

can you please say me where to ad this exactyl?

At the end of the CREATE TABLE query:
Code: [Select]
CREATE TABLE `cpg15x_cms` (
  `ID` int(11) NOT NULL auto_increment,
  `catid` int(11) NOT NULL default '0',
  `title` varchar(255) NOT NULL default '',
  `content` text NOT NULL default '',
  PRIMARY KEY  (`ID`, `catid`),
  FULLTEXT KEY `title` (`title`,`content`)
) ENGINE=MyISAM AUTO_INCREMENT=1;
Logged

flamendeShana

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: MiniCMS plugin for cpg1.5.x
« Reply #81 on: October 17, 2014, 03:34:21 pm »

ok now i have this table, but i get a new error now...
While executing query 'SELECT * FROM cpg15x_cms WHERE conid='0' AND type='0' ORDER BY cpos' in plugins/minicms/codebase.php on line 92

mySQL error: Unknown column 'conid' in 'where clause'
data: /var/www/html/foto/include/functions.inc.php - Zeile: 272
Logged

flamendeShana

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: MiniCMS plugin for cpg1.5.x
« Reply #82 on: October 17, 2014, 03:37:11 pm »

oh ok, i have post to eraly, i'm soory, i have reinstalled the plugin now, it seems it work now,

thanks for the support

is there any problem that the rest of copermine is in innodb?
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 721
    • GMC Design Photo Gallery
Re: MiniCMS plugin for cpg1.5.x
« Reply #83 on: October 17, 2014, 11:11:09 pm »

is there any problem that the rest of copermine is in innodb?
Should be fine... You might encounter another plugin that uses 'FULLTEXT' - but you know what to do now...
Once your ISP upgrades MySQL to 5.6 (currently 5.5.38) - then you can use innodb for that too...
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

flamendeShana

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: MiniCMS plugin for cpg1.5.x
« Reply #84 on: October 18, 2014, 07:48:48 pm »

thanks for suppoert,
i running and admin my own server at home,
but the Ubuntu 12.04 LTS version dont got the upgrade to mysql 5.6 yet... (i am waiting for it ;) so that there is no trouble if i will run the hole server on a puplic server with the same system without root [i cant manage a real server self])
Logged

Tankertom

  • Contributor
  • Coppermine regular visitor
  • ***
  • Offline Offline
  • Posts: 73
Re: MiniCMS plugin for cpg1.5.x
« Reply #85 on: June 20, 2015, 08:49:55 am »

it is possible to integrate the CKEditor?, or where what needs to be adjusted

VG TT
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 721
    • GMC Design Photo Gallery
Re: MiniCMS plugin for cpg1.5.x
« Reply #86 on: June 26, 2015, 01:56:13 pm »

it is possible to integrate the CKEditor?, or where what needs to be adjusted

VG TT
CKEditor is of course the replacement for FCKeditor that is included in the MiniCMS plugin.

A simple google search on converting finds:
http://docs.cksource.com/CKEditor_3.x/Howto/Upgrade_from_FCKeditor:
Quote
How do I Upgrade My FCKeditor to the Latest CKEditor Release?
...
However, since CKEditor was a complete rewrite of FCKeditor, with lots of changes in how the internal stuff works, no automatic upgrade path is available.

http://docs.cksource.com/CKEditor_3.x/Developers_Guide/FCKeditor_CKEditor_Configuration_Mapping
Quote
Configuration Settings Mapping Between FCKeditor and CKEditor

and one possible band-aid:
http://david.dw-perspective.org.uk/da/index.php/computer-resources/migrating-from-fckeditor-to-ckeditor-without-changing-any-code/
Quote
Migrating from FCKeditor to CKeditor without changing any code
Here’s a shim to allow you to swap FCKeditor for CKeditor without changing any application code.
(This may be a short term workaround - but the plugin should really be reworked to invoke CKEditor directly in my opinion...)

I've had this on my list to look at - but I haven't had the time to do so yet...
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

Tankertom

  • Contributor
  • Coppermine regular visitor
  • ***
  • Offline Offline
  • Posts: 73
Re: MiniCMS plugin for cpg1.5.x
« Reply #87 on: June 26, 2015, 02:47:08 pm »

I do realize that it is implemented in version 3. It's about the next version of me. There were made some adjustments that I do not know where they were made. A simple upgrade enough I do not think so. :o

TT
Logged
Pages: 1 2 3 4 [5]   Go Up
 

Page created in 0.017 seconds with 21 queries.