Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Au secours ! Connexion impossible  (Read 5442 times)

0 Members and 1 Guest are viewing this topic.

rhyss

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Au secours ! Connexion impossible
« on: November 13, 2009, 05:02:03 pm »

Bonjour,

Je viens de faire avec coppermine une galerie pour notre club photo. Pour la deuxième fois, impossible à tous les membres du club de se connecter. Certains, par ailleurs, ont pu, jusqu'à hier télécharger des photos sans problème. Je dis sans problème, mais ce n'est pas tout à fait vrai. Cette situation s'était déjà produite il y a une quinzaine de jours et j'ai dû aller dans la base de données pour arranger la situation.
Les photos téléchargées apparaissent toujours, avec les noms de leurs auteurs. Mais maintenant, quand les auteurs en question veulent se connecter, coppermine les reconnaît dans un premier temps et... leur dit bonjour... mais, en haut, reste la mention "s'identifier" au lieu du login, et comme j'ai réglé la configuration pour que seuls les personnes enregistrées puissent télécharger, plus personne n'a accès au téléchargement et tout ce qui va avec.

Quand je fais la liste des membres, seuls les administrateurs apparaissent.

Depuis le début, j'ai toute une tartine de message d'erreur qui s'affiche dans le bas de mes pages... Mais comme je n'y connais rien, je ne peux fatalement pas comprendre, et donc, pas réparer. Si quelqu'un peut venir à mon secours, merci de me le dire, je rendrai alors la "tartine" publique, ou je la copierai sur ce post.

Le site est hébergé par Free. J'ai lu dans un post qu'il fallait créer à la racine un dossier "sessions" (on ne met rien dedans ?) et j'ai recopié le fichier .htaccess que j'ai balancé par ftp directement dans le dossier coppermine également.

Au passage, est-il possible de faire un pont avec spip 2.0 ?

Merci de votre aide.
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: Au secours ! Connexion impossible
« Reply #1 on: November 13, 2009, 06:59:14 pm »

Bonjour,

sans lien vers le site, difficile de donner une réponse cohérente (c'est dit et redit très régulièrement et c'est un des points importants des règles de ce forum)
deuxième règle du forum: une seule question par sujet !
comme c'est votre premier post, on va âtre indulgent, mais il ne faudrait pas que ça ce reproduise  ;)
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

rhyss

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Au secours ! Connexion impossible
« Reply #2 on: November 13, 2009, 09:42:20 pm »

Tout d'abord, merci pour la rapidité de la réponse. Bien sûr qu'il faut l'adresse du site, ::) la voici donc :
http://sectionphotoasc.free.fr/coppermine
Je vais de ce pas rendre le message d'erreur public...
A bientôt...
Logged

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: Au secours ! Connexion impossible
« Reply #3 on: November 13, 2009, 10:04:51 pm »

Il semblerait que vous ayez activé l'option BRIDGE, il n'est pas certain que ce soit la cause du problème, mais supprimez cette option pour vérifier.
Profitez de votre passage pour mettre à jour votre Coppermine noté 1.4.20 alors que la version actuelle est 1.4.25
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: Au secours ! Connexion impossible
« Reply #4 on: November 13, 2009, 10:13:57 pm »

Quote
Il semblerait que vous ayez activé l'option BRIDGE, il n'est pas certain que ce soit la cause du problème, mais supprimez cette option pour vérifier.
Pas sur  ;) par contre il faut désactiver l'affichage des avertissement et du mode de déboggage... (c'est dans l'administration)
Quote
Profitez de votre passage pour mettre à jour votre Coppermine noté 1.4.20 alors que la version actuelle est 1.4.25
oui, c'est même indispensable et après avoir lancé le script update.php il est fort possible que le problème se résolve...
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

rhyss

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Au secours ! Connexion impossible
« Reply #5 on: November 13, 2009, 11:04:10 pm »

Je suis allée dans utilitaires, gestionnaire de bridge : ce qui est coché, c'est la ligne où je suis sensée écrire moi- même le nom du programme que j'utilise. Hors il n'y a rien d'écrit dans la ligne et je ne peux pas décocher la marque qui est devant cette ligne.

J'ai fermé les options d'affichage du déboggage.
Mais pour ce qui est de la mise à jour... ouille ouille ouille... là je suis perdue !!! J'ai regardé dans la documentation, comme dit sur le forum... Et je ne comprends pas tout... Je vais reprendre tout ça... calmement, il  risque d'y en avoir pour un moment !
Bon, 1 faire la sauvegarde de la base de donnée, j'espère que je saurai faire en allant dans la base de données. Par contre dans la doc, on dit de créer un répertoire edit avec le même CHMOD que le répertoire albums. Je ne sais pas du tout comment on accède à ce CHMOD pour le vérifier...
Bon, je tente le reste...
« Last Edit: November 14, 2009, 01:49:40 am by Pascal YAP »
Logged

rhyss

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Au secours ! Connexion impossible
« Reply #6 on: November 13, 2009, 11:50:29 pm »


Je suis allée dans ma base de données. Je trouve "exporter" mais pas sauvegarder. Ça revient au même ? Dans la documentation Coppermine il est écrit "dump" quand il est question de sauvegarde. Qu'est-ce que cela signifie ?
Logged

rhyss

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Au secours ! Connexion impossible
« Reply #7 on: November 14, 2009, 12:58:46 am »

Eh bien voilà la version 1.4.25 installée. Je suis allée dans "versioncheck.php". 1.4.25 est bien mentionné et je n'ai rien vu en rouge (rien en vert non plus d'ailleurs !)

Rien n'a changé dans la galerie. Seuls les administrateurs apparaissent dans les membres. Les autres n'ont pas réapparu... :-\
Logged

rhyss

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Au secours ! Connexion impossible
« Reply #8 on: November 14, 2009, 01:43:11 am »

Ouf ! Les membres sont de retour...
Ils étaient tous présents dans la base de données, mais leur groupe avait disparu. J'ai donc recréé le groupe. J'ai changé l' "id" pour redonner à ce groupe celui qui figurait dans la liste des membres. Mais si quelqu'un pouvait me dire ce qui provoque cette disparition ! C'est la deuxième fois que ce genre de chose se produit ! Est-ce que cette manipulation était de toute façon nécessaire après le passage à coppermine 1.4.25 et est-ce que cette fois ça ne risque plus de se reproduire ? Ou est-ce que la mise à jour ne peut pas avoir résolu le problème de manière durable ?
Merci de votre aide
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: Au secours ! Connexion impossible
« Reply #9 on: November 14, 2009, 08:33:48 am »

content que ce soit rentré dans l'ordre.
le problème venait peut être du fait que effectivement vous aviez coché la case bridge personnalisé et que les données n'étaient pas les bonnes (il faudrait confirmer ce que vous aviez fait)
il ne me semble pas qu'il y ait un bridge pour SPIP (il faudrait chercher éventuellement sur le forum SPIP) mais ce point doit faire l'objet d'un autre sujet.
Pour les instructions concernant la mise à jour et plus particulièrement pour la sauvegarde de la base de donnée, une explication plus détaillée peut être trouvée sur le wiki
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

rhyss

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Au secours ! Connexion impossible
« Reply #10 on: November 14, 2009, 09:38:02 am »

Bonjour,

Je vous remercie de vote aide. J'ai encore une petite question au sujet de ce forum : Au moment d'ajouter un commentaire à la suite du précédent que j'avais écrit, j'ai voulu effacer le précédent pour fusionner les 2. Je pensais effacer en cliquant sur la croix. Je me suis retrouvée avec un commentaire marqué de rouge. Quelle en est la signification ? On ne peut pas effacer ce qu'on a écrit avant qu'une réponse ait été apportée ?
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9093
  • aka Frantz
    • Ma galerie
Re: Au secours ! Connexion impossible
« Reply #11 on: November 14, 2009, 09:57:07 am »

conformément aux règles de ce forum, merci d'ouvrir une nouvelle discussion avec cette question.
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

rhyss

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Au secours ! Connexion impossible
« Reply #12 on: November 14, 2009, 10:00:09 am »

OK.
En tout cas, encore merci
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 24 queries.