Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Problem with serbian characters ŠĐČƎ=?  (Read 9750 times)

0 Members and 1 Guest are viewing this topic.

vlado85

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
[Solved]: Problem with serbian characters ŠĐČƎ=?
« on: August 19, 2009, 08:36:28 pm »

hello, I have a problem with characters on the Coppermine gallery 1.4.25. Collation gallery is on the Unicode (utf-8), and my tables is utf8_general_ci.    
I have a Serbian Latin translation and the characters ŠĐČƎ are converted to -?-. Serbian Cyrillic translation of all the converted to -?-  ???

My joomla site is connected with a gallery with Mehdi bridge. This problem is appearing before the junction.
   
Gallery is located on the following link:

http://www.palelive.com/cpg/index.php

Please help.
« Last Edit: August 20, 2009, 03:06:45 pm by Joachim Mόller »
Logged

Nibbler

  • Guest
Re: Problem with serbian characters ŠĐČƎ=?
« Reply #1 on: August 19, 2009, 09:11:03 pm »

Have you modified serbian.php? If so, did you make sure to save it as UTF-8?
Logged

vlado85

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: Problem with serbian characters ŠĐČƎ=?
« Reply #2 on: August 19, 2009, 10:02:40 pm »

Yes I have changed some files. Now I download a new gallery and again upload  serbian.php, serbian_cy.php and croatian.php, but the problem is still there.   ???
Logged

Joachim Mόller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Problem with serbian characters ŠĐČƎ=?
« Reply #3 on: August 20, 2009, 09:24:11 am »

What tool do you use to upload your files to the server? Some all-in-one tools (like notorious MS Frontpage and it's built-in FTP client) tend to "beautify" the files they're just suppossed to transfer. The special chars from content coming from the db (like album names) appear to work as expected, but the stuff that comes from the language file (the menu etc) looks garbled. Could you temporarily delete the folder http://www.palelive.com/cpg/lang/ (back it up or rename it) and in that place upload the vanilla lang folder that comes with a fresh coppermine package. Please use a plain FTP app like FileZilla to do that.
Logged

vlado85

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: Problem with serbian characters ŠĐČƎ=?
« Reply #4 on: August 20, 2009, 01:50:49 pm »

I used FileZilla. Once again, I do everything again. Deleted lang folder and again upload. All languages are working fine except for the Croatian and Serbian (Latin and Cyrillic), even Russian and Bulgarian Cyrillic work fine! This is impossible. That is not a question of a problem with some config file or something similar?

http://www.palelive.com/cpg
Logged

vlado85

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: Problem with serbian characters ŠĐČƎ=?
« Reply #5 on: August 20, 2009, 02:02:43 pm »

lol I'm set!

I switched serbian.php file to Encode in UTF-8 without BOM and the thing is work!

Thanks for your help!
Logged

Nibbler

  • Guest
Re: Problem with serbian characters ŠĐČƎ=?
« Reply #6 on: August 20, 2009, 02:50:14 pm »

It already is encoded like that.
Logged

vlado85

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: Problem with serbian characters ŠĐČƎ=?
« Reply #7 on: August 20, 2009, 03:03:02 pm »

   
hm I do not know, but the translation is now working!  :)
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1498
  • aka 'i-imagine'
    • Home Page
Re: [Solved]: Problem with serbian characters ŠĐČƎ=?
« Reply #8 on: August 20, 2009, 03:08:26 pm »

@ vlado85 ,

What are you using to unzip on your local pc? And also please, what is the operating system of that pc?

Thanks

[off topic] The reason that I am asking is that I have been having strange (and aggravating) zip/unzip issues here [/off topic]

vlado85

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: [Solved]: Problem with serbian characters ŠĐČƎ=?
« Reply #9 on: August 20, 2009, 03:51:12 pm »

I use TUGZip, and I have Win XP SP3...
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 20 queries.