Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Unable to log into Coppermine after bridging with phpBB3  (Read 6353 times)

0 Members and 1 Guest are viewing this topic.

josec

  • Coppermine newbie
  • Offline Offline
  • Posts: 16

I have the following issue when trying to bridge coppermine and phpBB3:

I could not log into Coppermine photo gallery. When logging in, I get redirected to the forum as expected, and get the confirmation that I'm logged in forum.
But once it goes back to Coppermine, I get the following in my URL:
http://www.manaboconnexion.com/photo/?sid=efa615c65bfdeb834e0682767c99a682

Did I miss a step in the bridging process? I tried to follow, as much as possible,  your instruction(s) in this forum (even cleared the cookies). The only
thing I'm not too sure of is the updating of udb_base.inc.php file. Could that be the issue?

Thanks for the help.

Best Regards.


Coppermine install: http://www.manaboconnexion.com/photo/
Forum install: http://www.manaboconnexion.com/forum/
Coppermine version: cpg1.4.19
Forum version: phpBB 3.0.4
Test user account: josec for username / Columbia28 for password

BridgeManager settings:
Forum URL:  http://www.manaboconnexion.com/forum
Relative path to your BBS's config file:  ../forum/ 
Use post-based groups?:  1
Cookie name/preifx (if applicable):phpbb3
« Last Edit: January 28, 2009, 08:32:16 pm by Nibbler »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Unable to log into Coppermine after bridging with phpBB3
« Reply #1 on: January 28, 2009, 10:47:11 am »

What bridge file did you use? You can not use the one that comes with coppermine, as that was made for phpbb2.x. Did you actually download the phpbb3 bridge file contributed by Nibbler?
Logged

josec

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Unable to log into Coppermine after bridging with phpBB3
« Reply #2 on: January 28, 2009, 06:47:52 pm »

Yes- I did exactly as described in Nibbler's thread. I edited both the bridgemgr.hlp and ucp.php files and even verified that the typo error had been fixed. Then uploaded the file to my server in the bridge folder.

Do I need to delete the old bridge file? I don't think it's being used, though, because I was getting fatal error before the upgrade.

Do I need to change anything in phpBB?

Thanks for the quick response.

Best Regards.
Logged

Nibbler

  • Guest
Re: Unable to log into Coppermine after bridging with phpBB3
« Reply #3 on: January 28, 2009, 07:44:08 pm »

Your forum's cookie prefix is not phpbb3. It is phpbb3_pczjy. Set that in the bridge manager.
Logged

josec

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Unable to log into Coppermine after bridging with phpBB3
« Reply #4 on: January 28, 2009, 08:09:28 pm »

I know. I've tried both with and without the rest of the cookie name (_pczjy). No difference.

I just changed it back to the full name.
Logged

Nibbler

  • Guest
Re: Unable to log into Coppermine after bridging with phpBB3
« Reply #5 on: January 28, 2009, 08:11:26 pm »

Test account works for me now.
Logged

josec

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Unable to log into Coppermine after bridging with phpBB3
« Reply #6 on: January 28, 2009, 08:31:46 pm »

That's very strange ???. I'm pretty sure I've flipped back and forth between the two cookie prefixes. Just wasted 3 days (that's all!)

It seems to work now. Your help is much appreciated.

Best Regards.

Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 22 queries.