Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Image blocks not showing in Zikula  (Read 10069 times)

0 Members and 1 Guest are viewing this topic.

BlackChart

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Image blocks not showing in Zikula
« on: December 04, 2008, 06:46:25 pm »

Hi,

I'm trying to get pnCPG to work correctly under Zikula, so far it work pretty much as I had in mind except for the blocks...

When adding one of the blocks that are intended to show an image, nothing shows (that mean the whole block and not only the image)...
When using the one to show the latest albums, the list shows...

Any ideas??

The site can be viewed at http://new.t3nettet.dk which are the development address for my site..

Regards,
Morten 
Logged

casNuy

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 671
  • My other hobby
    • Nuy Community
Re: Image blocks not showing in Zikula
« Reply #1 on: December 07, 2008, 11:46:27 am »

Hi Morten,

I am a bit behind and have not checked out Zikula yet.
Will download and install to see what the difference is.
To be continued............
Logged

BlackChart

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Image blocks not showing in Zikula
« Reply #2 on: December 07, 2008, 11:57:01 am »

Thank you, will be looking forward to some solution :)
Logged

casNuy

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 671
  • My other hobby
    • Nuy Community
Re: Image blocks not showing in Zikula
« Reply #3 on: December 07, 2008, 10:11:10 pm »

You need to replace
Code: [Select]
$true = mysql_select_db($std_db) ;
with
Code: [Select]
$true = pnDBInit();
in the code of the block
Logged

BlackChart

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Image blocks not showing in Zikula
« Reply #4 on: December 08, 2008, 04:22:16 pm »

That didn't do any changes to the issue with the blocks not showing on the page...
Logged

casNuy

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 671
  • My other hobby
    • Nuy Community
Re: Image blocks not showing in Zikula
« Reply #5 on: December 08, 2008, 06:09:15 pm »

Which block are you having the issue with?
Can I have an account with enough authorisation to do some verifciation?
You could send me a PM.
Logged

BlackChart

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Image blocks not showing in Zikula
« Reply #6 on: December 08, 2008, 07:07:43 pm »

I've tried with random block and the one called block...

I'll create a zikula admin account for you, PM will follow..
Logged

casNuy

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 671
  • My other hobby
    • Nuy Community
Re: Image blocks not showing in Zikula
« Reply #7 on: December 13, 2008, 06:02:42 pm »

the other thing which need adjusting is to replave this line
Code: [Select]
themesideblock($blockinfo);
with
Code: [Select]
return themesideblock($blockinfo);

That is it.
Logged

BlackChart

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Image blocks not showing in Zikula
« Reply #8 on: December 13, 2008, 08:04:38 pm »

Thank you, now it works :)
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 21 queries.