Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 3 [4] 5 6 7 8 ... 19   Go Down

Author Topic: Coppermine Forum Plugin (cpgforum)  (Read 378514 times)

0 Members and 1 Guest are viewing this topic.

whunlimited

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Coppermine Forum Plugin (cpgforum)
« Reply #60 on: May 22, 2008, 05:59:40 pm »

Is there any way to restrict unregistered guests from viewing the forum?
Logged

bossbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Coppermine Forum Plugin (cpgforum)
« Reply #61 on: May 23, 2008, 01:26:42 am »

yes there is.
just go to forum manager/settings
there is an option... Allow guests to browse the forum  just set it to no.
Logged

whunlimited

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Coppermine Forum Plugin (cpgforum)
« Reply #62 on: May 23, 2008, 04:04:21 am »

Thanks. Also just found out that my users can't post a new topic but somehow I am able to though I am admin of course. They get an error message when trying to post a new topic. Any way to fix this?

sorry modified this message for the post after this one. the message says "object doesnt support property or method" I actually tried it on IE and hitting the new topic doesn't even do anything and the numbers that are supposed to display the boards of how many post and views don't even align on that table.
« Last Edit: May 23, 2008, 07:08:43 am by whunlimited »
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Coppermine Forum Plugin (cpgforum)
« Reply #63 on: May 23, 2008, 06:41:00 am »

Don't forget to post the error message then..
Logged

foulu

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 236
  • uhm
Re: Coppermine Forum Plugin (cpgforum)
« Reply #64 on: May 23, 2008, 08:01:24 am »

Hi,

I have look at the "new topic" bug, it also happend with "reply" button, too. I tested the plugin all the time in FF so I can't find that bug by myshelf. Base on bug fighting ^^ I release a new version of my plugin. It fix all the bug that found until now. Check starter post for it.

Also, check this post of me:

http://forum.coppermine-gallery.net/index.php/topic,52804.msg256549.html#new

smiley won't working in IE if you still have this bug in your gallery.

whunlimited

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Coppermine Forum Plugin (cpgforum)
« Reply #65 on: May 23, 2008, 08:20:07 am »

thank you for updating it. The new topic works fine now and the columns align on both firefox and IE. And thanks for adding the move topic feature.
Logged

pixstreet

  • Coppermine novice
  • *
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 25
    • pixstreet.co.uk
Re: Coppermine Forum Plugin (cpgforum)
« Reply #66 on: May 23, 2008, 08:22:26 pm »


after installong the forum plug in, i have come across a couple of problems.

1. when using Internet explorer, the message preview feature does not work, when creating a message.

2. also when using Internet Explorer, when creating a message/post the window is wider than when using Firefox and needs to use a scroll bar, which does not look as professional as in Firefox.

It appears that the problems are related to Internet Explore, but I monitor users prefered browsers and need to use both.



http://www.pixstreet.co.uk
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine Forum Plugin (cpgforum)
« Reply #67 on: May 26, 2008, 04:43:33 pm »

hi foulu.. i've tested version 1.1.1 and found some things:
  • "Please select a destination:" can't be translated in the language-file
  • locked topics can't be viewed by admins or normal users
  • non-admins can't delete their own posts
  • the icon in the forum view is depending on the last post.. i think it should depend on the first post (topic-starter)
  • if you delete the last post in a topic, in the forum view there isn't displayed a icon anymore and the time is wrong (01.01.1970)
  • a locked sticky topic has the "sticky icon" but i think it's better to use the "locked icon"
  • if you modify a post, there should be an "cancel button"
  • whitespaces in the topic name aren't catched (e.g. you can name a topic like ' ')
  • forum.php?msg=xyz show nothing (no error message or something like this).. you can access this link from the board/forum view
  • in child boards are shown strange symbols in front of the boards
  • you can move a board in its own child boards.. this will end in an infinite loop
  • attached updated version of german.php

i don't know what's on your to-do-list.. but here are some interesting things:
- polls
- anchors for posts (for easy access from the info center and after making a post etc.)
- attachments?
- show when and who modified a post below a post (e.g. "modified by muu on 26.05.2008")
- locked forum where nobody can create a new topic (for archiving old topics)
- display new (not-viewed) posts for each user and use the appropriate icons in the board view + button to mark all posts as "viewed"


good work so far :)

-
muu
« Last Edit: May 26, 2008, 05:28:31 pm by eenemeenemuu »
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine Forum Plugin (cpgforum)
« Reply #68 on: May 26, 2008, 08:12:45 pm »

hm.. guests can't view a topic (again): http://photoalbum.ph.funpic.de/cpg/forum.php?topic=517
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Coppermine Forum Plugin (cpgforum)
« Reply #69 on: May 26, 2008, 08:16:48 pm »

Eenemeenemuu, thanks for the work you put into perfecting this forum plugin but before you do anything else you had better download 1.4.18 asap and do a upgrade. Running <!--Coppermine Photo Gallery 1.4.10 (stable)--> is just not done concidering the all the security updates that are implemented into cpg since then.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine Forum Plugin (cpgforum)
« Reply #70 on: May 26, 2008, 08:48:12 pm »

Eenemeenemuu, thanks for the work you put into perfecting this forum plugin but before you do anything else you had better download 1.4.18 asap and do a upgrade. Running <!--Coppermine Photo Gallery 1.4.10 (stable)--> is just not done concidering the all the security updates that are implemented into cpg since then.

thanks for the tip hein, but i've done all the security updates by hand, because i have a highly modded cpg and the "automatic" updates would destroy my mods ;) thats why version 1.4.10 is still displayed

-
muu
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Coppermine Forum Plugin (cpgforum)
« Reply #71 on: May 26, 2008, 08:55:25 pm »

Your risk. It's not advisable plus in some cases you end up getting no support because of the lagging in version updates. See if you can implement all the changes since 1.4.10 manually just to make sure your are up to speed with 1.4.18
Logged

dork313

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
    • NINart
Re: Coppermine Forum Plugin (cpgforum)
« Reply #72 on: May 26, 2008, 10:41:29 pm »

I really want this plugin to work but after creating my first topic, I go to view it and it tells me, "You don't have permission to perform this operation.  "! Everything seemed to install properly and I haven't seen any errors other than this. http://ninart.1kwordmigraine.com/forum.

*edit* Please disregard this post. It is working fine now. I'm not sure what happened with the first post but all of the others are working properly.

*edit 2* After reading the post above, which states noone can view a locked thread, I realized that the thread I was unable to view was indeed locked so that must've been the issue. On another note, I use the Chaoticsoul theme, how do you go about setting up a .css file for a different theme? I found where the .css files are located and I took a peak at them but it only styles the link colors and/or effects. With the chaoticsoul theme, the forum is completely black and there is no distinguishing lines or colors to separate the columns or post.
« Last Edit: May 29, 2008, 12:58:34 am by dork313 »
Logged

Tjnashster

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 27
Re: Coppermine Forum Plugin (cpgforum)
« Reply #73 on: May 29, 2008, 11:51:40 am »

After install i just get the error
"There was an error while processing a database query"
any ideas??
Logged

foulu

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 236
  • uhm
Re: Coppermine Forum Plugin (cpgforum)
« Reply #74 on: May 29, 2008, 11:59:09 am »

hi foulu.. i've tested version 1.1.1 and found some things:
  • "Please select a destination:" can't be translated in the language-file
  • locked topics can't be viewed by admins or normal users
  • non-admins can't delete their own posts
  • the icon in the forum view is depending on the last post.. i think it should depend on the first post (topic-starter)
  • if you delete the last post in a topic, in the forum view there isn't displayed a icon anymore and the time is wrong (01.01.1970)
  • a locked sticky topic has the "sticky icon" but i think it's better to use the "locked icon"
  • if you modify a post, there should be an "cancel button"
  • whitespaces in the topic name aren't catched (e.g. you can name a topic like ' ')
  • forum.php?msg=xyz show nothing (no error message or something like this).. you can access this link from the board/forum view
  • in child boards are shown strange symbols in front of the boards
  • you can move a board in its own child boards.. this will end in an infinite loop
  • attached updated version of german.php

i don't know what's on your to-do-list.. but here are some interesting things:
- polls
- anchors for posts (for easy access from the info center and after making a post etc.)
- attachments?
- show when and who modified a post below a post (e.g. "modified by muu on 26.05.2008")
- locked forum where nobody can create a new topic (for archiving old topics)
- display new (not-viewed) posts for each user and use the appropriate icons in the board view + button to mark all posts as "viewed"


good work so far :)

-
muu

Well, I'm busy these day and don't have much time spend to my forum plugin but I think I should say something. I already note down all error and fix in my loachost. About new feature, I will take some easy & basic one first and make all of the code running perfect first, then go to advance ones.

foulu

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 236
  • uhm
Re: Coppermine Forum Plugin (cpgforum)
« Reply #75 on: May 29, 2008, 12:01:34 pm »

I really want this plugin to work but after creating my first topic, I go to view it and it tells me, "You don't have permission to perform this operation.  "! Everything seemed to install properly and I haven't seen any errors other than this. http://ninart.1kwordmigraine.com/forum.

*edit* Please disregard this post. It is working fine now. I'm not sure what happened with the first post but all of the others are working properly.

*edit 2* After reading the post above, which states noone can view a locked thread, I realized that the thread I was unable to view was indeed locked so that must've been the issue. On another note, I use the Chaoticsoul theme, how do you go about setting up a .css file for a different theme? I found where the .css files are located and I took a peak at them but it only styles the link colors and/or effects. With the chaoticsoul theme, the forum is completely black and there is no distinguishing lines or colors to separate the columns or post.

Well, I already think about the theme thing because my forum is base on coppermine forum style sheet. If you want to change your forum theme, just replace the core style sheet in .css file.

foulu

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 236
  • uhm
Re: Coppermine Forum Plugin (cpgforum)
« Reply #76 on: May 29, 2008, 12:04:47 pm »

After install i just get the error
"There was an error while processing a database query"
any ideas??


please enable debug mode and post the error.

Tjnashster

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 27
Re: Coppermine Forum Plugin (cpgforum)
« Reply #77 on: May 29, 2008, 03:40:13 pm »

the error is
While executing query "SELECT * FROM `cpg14x_fr_categories` ORDER BY cat_order ASC;" on 0

mySQL error: Table '8821db.cpg14x_fr_categories' doesn't exist

the debug is

Code: [Select]
USER:
------------------
Array
(
    [ID] => 9f191605cda342cb363541c7c803df55
    [am] => 1
    [lang] => english_gb
    [liv] => Array
        (
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => admin
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg14x_filetypes; (0s)
    [1] => select * from cpg14x_plugins order by priority asc; (0.001s)
    [2] => delete from `8821db`.cpg14x_sessions where time<1212064577 and remember=0; (0s)
    [3] => delete from `8821db`.cpg14x_sessions where time<1210858577; (0s)
    [4] => select user_id from `8821db`.cpg14x_sessions where session_id = '358175874e845a61b74876ba5ee3f870' (0s)
    [5] => select user_id as id, user_password as password from `8821db`.cpg14x_users where user_id=1 (0s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `8821db`.cpg14x_users AS u INNER JOIN `8821db`.cpg14x_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
    [7] => SELECT user_group_list FROM `8821db`.cpg14x_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg14x_usergroups WHERE group_id in (1) (0s)
    [9] => SELECT group_name FROM  cpg14x_usergroups WHERE group_id= 1 (0s)
    [10] => update `8821db`.cpg14x_sessions set time='1212068177' where session_id = '358175874e845a61b74876ba5ee3f870' (0s)
    [11] => SELECT user_favpics FROM cpg14x_favpics WHERE user_id = 1 (0s)
    [12] => SHOW TABLES LIKE 'cpg14x_cms_config' (0s)
    [13] => SELECT * FROM cpg14x_cms_config (0s)
    [14] => DELETE FROM cpg14x_banned WHERE expiry < '2008-05-29 13:36:17' (0s)
    [15] => SELECT * FROM cpg14x_banned WHERE (ip_addr='88.110.98.170' OR ip_addr='88.110.98.170' OR user_id=1) AND brute_force=0 (0s)
    [16] => SELECT value FROM `cpg14x_config` WHERE name='fr_installed'; (0s)
    [17] => SELECT COUNT(*) FROM cpg14x_pictures WHERE approved = 'NO' (0s)
    [18] => SELECT * FROM `cpg14x_fr_categories` ORDER BY cat_order ASC; (0s)
)

==========================
GET :
------------------
Array
(
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 4.4.2 - OK
------------------
mySQL version: 4.0.27-log
------------------
Coppermine version: 1.4.18(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.28 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support: 1
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.0.25
MYSQL_MODULE_TYPE none
MYSQL_SOCKET /tmp/mysql.sock
MYSQL_INCLUDE no value
MYSQL_LIBS no value
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.1.4
Linked Version 1.1.4
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | On | On
safe_mode_exec_dir | /usr/local/bin/ | /usr/local/bin/
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | /usr/local/bin/ | /usr/local/bin/
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .: | .:
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | me@localhost.com | me@localhost.com
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | sweeper1.fast.net.uk | sweeper1.fast.net.uk
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 300 | 300
max_input_time | -1 | -1
upload_max_filesize | 10M | 10M
post_max_size | 8M | 8M
==========================
Page generated in 0.415 seconds - 19 queries in 0.001 seconds - Album set : ; Meta set: ;
« Last Edit: May 29, 2008, 04:20:53 pm by Hein Traag »
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Coppermine Forum Plugin (cpgforum)
« Reply #78 on: May 29, 2008, 03:44:09 pm »

the error is
While executing query "SELECT * FROM `cpg14x_fr_categories` ORDER BY cat_order ASC;" on 0

mySQL error: Table '8821db.cpg14x_fr_categories' doesn't exist

it seems, that you haven't run the "adaptor plugin", which creates the needed tables.. try to install this plugin if you haven't or try to reinstall..


-
muu
Logged

Rockas

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 54
  • **Spaceman**
    • Windows and Souls
Re: Coppermine Forum Plugin (cpgforum)
« Reply #79 on: May 29, 2008, 06:08:22 pm »

is it me or the latest version still appears as "1.1.0" and not "1.1.1"?

@foulu
Great work! I loved this option 'cause i was looking for something simple that I could easily integrate with my gallery.
Thank you for this
Any estimated date for a new release? Specially the part we can't access locked threads not even to erase them.

again... thank you.
Logged
My opinions may change but not the fact that I am right!
Pages: 1 2 3 [4] 5 6 7 8 ... 19   Go Up
 

Page created in 0.026 seconds with 22 queries.