Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: problème avec le mod anti-spam seulement en français...  (Read 10911 times)

0 Members and 1 Guest are viewing this topic.

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
problème avec le mod anti-spam seulement en français...
« on: September 21, 2006, 04:22:10 pm »

(re)salut,

j'ai installé le mod anti-spam d'Abbas Ali qui fonctionne impecablement en anglais, mais merde en français. J'ai pourtant vu et revu mes modifs du fichier french.php mais rien n'y fait: j'ai une croix rouge à la place de l'affichage du code de sécurité et mon message d'erreur en cas de validation est en anglais au lieu de reprendre celui que j'ai entré dans french.php.

Qq a une idée de l'origine du problème? Ça marche en français chez qq'un?

Merci de votre aide... :)
« Last Edit: September 22, 2006, 09:38:14 am by PYAP »
Logged

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: problème avec le mod anti-spam seulement en français...
« Reply #1 on: September 21, 2006, 05:28:45 pm »

Bonjour Loïc,
Quote
j'ai installé le mod anti-spam d'Abbas Ali qui fonctionne impecablement en anglais, mais merde en français.
S'agit-il du MOD ou du Plugin ? (bienque celà ne change rien. Les deux solutions utilisent FRENCH.PHP)

Ne serait-ce pas les caractères UTF-8 qui concernent ce MOD qui posseraient problème ?

A savoir :
Code: [Select]
'non_exist_comment' => 'Le commentaire sélectionné n\'existe pas.',
Code: [Select]
'captcha_error' => 'Le code de confirmation ne correspond pas. The confirmation code didn\'t matched',
Code: [Select]
'report_comment_title' => 'Envoyer ce commentaire à l\'administrateur', //cpg1.4
Code: [Select]
'confirm' => 'Confirmation',
PYAP
« Last Edit: September 21, 2006, 05:39:38 pm by PYAP »
Logged

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
Re: problème avec le mod anti-spam seulement en français...
« Reply #2 on: September 21, 2006, 05:49:40 pm »

J'ai pas trop compris ta question, mais s'il y a effectivement des caractères accentués dans les messages que j'ai ajouté, j'en ai d'autres dans le fichier french.php qui fonctionne correctement pour tout le reste...
Logged

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: problème avec le mod anti-spam seulement en français...
« Reply #3 on: September 21, 2006, 06:12:25 pm »

Quote
S'agit-il du MOD ou du Plugin ?
Quote
J'ai pas trop compris ta question,
CAPTCHA était à l'origine un MOD. Ce qui nécessitait de tripoter le code.
Il y a désormais un Plugin qui a le mérite de ne demander qu'à être installé sans intervention du webmaster de la galerie.

C'est particulier votre problème parce que sur cette galerie il n'y a aucun problème. Elle utilise pourtant le code placé plus haut dans ce sujet.  ???

Dernier point : Votre hébergeur propose FREETYPE au moins ? (voir votre phpinfo.php)
PYAP
Logged

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
Re: problème avec le mod anti-spam seulement en français...
« Reply #4 on: September 21, 2006, 06:32:12 pm »

Ah, ok, je ne savais pas que c'était dispo sous forme de plugin, c'est le mod que j'ai installé.

Pour Freetype, je sais pô... Je suis chez Free.
Logged

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: problème avec le mod anti-spam seulement en français...
« Reply #5 on: September 21, 2006, 06:45:27 pm »

Quote
Pour Freetype, je sais pô... Je suis chez Free.
Disponible chez FREE  ;D
Il faut creuser ailleurs !

PYAP
Logged

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
Re: problème avec le mod anti-spam seulement en français...
« Reply #6 on: September 21, 2006, 06:51:55 pm »

Sur la galerie linkée (avec le thème qui pique les yeux ;D) , ça n'a pas l'air d'être le même mod à en juger par le code affiché...
Logged

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: problème avec le mod anti-spam seulement en français...
« Reply #7 on: September 21, 2006, 07:17:02 pm »

Quote
(avec le thème qui pique les yeux  ;D)
Ah bon  ;)

Quote
ça n'a pas l'air d'être le même mod à en juger par le code affiché...
Si si ! Mais il y a dans le code la possibilité de décider combien de caractères seront affichés.

Ce n'est pas là qu'il faut creuser  :D

PYAP
Logged

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
Re: problème avec le mod anti-spam seulement en français...
« Reply #8 on: September 21, 2006, 07:27:11 pm »

Tu le connais, le webmaster de cette galerie? Parcequ'à ce moment là, il peut toujours m'envoyer son fichier french.php que je vois si ça roule avec...
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9097
  • aka Frantz
    • Ma galerie
Re: problème avec le mod anti-spam seulement en français...
« Reply #9 on: September 21, 2006, 09:01:37 pm »

Quote
(avec le thème qui pique les yeux  Grin)
je suis assez d'accord  :D :D :D
Quote
Tu le connais, le webmaster de cette galerie?
je crois que oui  ;D
il me semble même que c'est Pyap qui a fait le theme et peut être même la galerie  :D
Il va donc falloir que tu t'excuse auprès de lui si tu veux qu'il te transmette son fichier, après une critique aussi franche de ses gouts, il risque de bouder un peu  :D :D :D :D
Mais, avec quelques caresses dans le sens su poil... ;) (bon oui je sors)
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
Re: problème avec le mod anti-spam seulement en français...
« Reply #10 on: September 21, 2006, 09:36:41 pm »

Oops, la boulette... :P

Euh... Dis, PYAP, euh... ah, c'est toi qui a fait ce... euh... joli thème, tout seul avec tes petits doigts? Félicitations. Normalement, je préfère le vert pomme avec l'orange fluo, mais là, curieusement, le bleu, ça va. Nickel. Je te le demande pas pour ma galerie, mais limite...

Voilà, voilà...

Euh, sinon, tu peux m'envoyer le fichier french.php que je voie ce que ça donne...

Logged

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: problème avec le mod anti-spam seulement en français...
« Reply #11 on: September 21, 2006, 10:08:02 pm »

Hey les Gars  ;D

Quote
Euh... Dis, PYAP, euh... ah, c'est toi qui a fait ce... euh... joli thème, tout seul avec tes petits doigts? Félicitations.
C'est une activité de plein air, qui par essence, pique les yeux  ;)
et j'adore que l'on me carresse dans le sens du poil  ;D  ;D
(et vous m'avez bien fait rire)

Ci-dessous le code de confirmation pour ces pages:

Code: [Select]
'non_exist_comment' => 'Le commentaire sélectionné n\'existe pas.',
'captcha_error' => 'Le code de confirmation ne correspond pas... Faites Back...',
puis :
Code: [Select]
'report_comment_title' => 'Envoyer ce commentaire à l\'administrateur', //cpg1.4
 'confirm' => 'Confirmation',

Je ne peux rien signaler de plus !

PYAP
Logged

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
Re: problème avec le mod anti-spam seulement en français...
« Reply #12 on: September 21, 2006, 10:25:13 pm »

j'ai copié ton code dans french.php et l'image apparait enfin. Mais tout par en vrille à côté de ça: les caractères spéciaux ne sont plus reconnus, la moitié des menus sont en anglais...  :-\ :-\ :-\
Logged

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: problème avec le mod anti-spam seulement en français...
« Reply #13 on: September 21, 2006, 10:38:30 pm »

Quote
j'ai copié ton code dans french.php et l'image apparait enfin.
Donc il y a un petit soucis dans votre French.php

Quote
Mais tout par en vrille à côté de ça....la moitié des menus sont en anglais...
Aïe que ce passe-t-il ?

Vérifiez deux ou trois fois votre fichier french.php, votre problème se situe là, nous venons de le voir.

PYAP
Logged

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
Re: problème avec le mod anti-spam seulement en français...
« Reply #14 on: September 21, 2006, 10:43:48 pm »

En fait quand j'écrase ma ligne:

Code: [Select]
  'non_exist_comment' => 'Le commentaire sélectionné n\'existe pas.',
par la tienne:

Code: [Select]
'non_exist_comment' => 'Le commentaire sélectionné n\'existe pas.',
l'image avec le code s'affiche correctement, mais les caractères spéciaux (à, é, ê... etc) ne sont plus reconnus et le menu de la galerie est en anglais.

Comprends pas, là. Ça me rapelle la galère pour passer du 1.3.x au 1.4.x... :-/

« Last Edit: September 21, 2006, 10:59:37 pm by Loïc »
Logged

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
Re: problème avec le mod anti-spam seulement en français...
« Reply #15 on: September 22, 2006, 09:34:14 am »

OK, c'est reglé. Il faut supprimer la ligne
Code: [Select]
require("include/init.inc.php"); dans le fichier captcha.php...

Merci pour votre aide... ;)
Logged

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: problème avec le mod anti-spam seulement en français...
« Reply #16 on: September 22, 2006, 09:38:02 am »

Bonjour Loïc,
Quote
OK, c'est reglé. Il faut supprimer la ligne
Code: [Select]
require("include/init.inc.php");dans le fichier captcha.php...

 ??? Je suis très étonné par cette solution ! Ce n'est pas tellement conventionnel  ;)

Le principal après tout, c'est que l'affichage soit correct  ;D

PYAP
Logged

Loïc

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 165
Re: problème avec le mod anti-spam seulement en français...
« Reply #17 on: September 22, 2006, 09:57:25 am »

Oui, il y a surement une solution moins radicale, car c'est définitivement un problème d'encodage. Un néérlandais qui avait le même problème l'a reglé en sauvegardant son fichier avec l'encodage ANSI...
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 21 queries.