Advanced search  

News:

cpg1.5.44 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.42 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Maintenance release cpg1.4.9 - upgrade recommended  (Read 72496 times)

0 Members and 1 Guest are viewing this topic.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Maintenance release cpg1.4.9 - upgrade recommended
« on: August 27, 2006, 04:09:07 PM »

The Coppermine dev team announces the release of cpg1.4.9.

Features:
The new release does not contain additional new features (compared to previous versions of cpg1.4.x), but contains fixes for several bugs. All Coppermine users are strongly encouraged to upgrade their coppermine version as soon as possible. Upgrade instructions are included in the package (refer to the index file inside the docs folder).

Languages:
The new package contains all language files that existed up till now:
Albanian, Basque, Brazilian Portuguese, Bulgarian, Chinese (Big5 and GB), Czech, Danish, Dutch, English (US and GB), Finnish, French, Galician, Georgian, German (informal "Du" and formal "Sie"), Greek, Hebrew, Hungarian, Italian, Japanese, Korean, Norwegian, Persian, Polish, Portuguese, Russian, Slovak, Slovenian, Spanish, Swedish, Turkish, Ukrainian

Download:
Get the new release cpg1.4.9 here: http://prdownloads.sourceforge.net/coppermine/cpg1.4.9.zip?download

Scope:
The maintenance release cpg1.4.9 of course contains all previous fixes of the 1.4.x-series as well as several minor issues that have been reported on the bugs board. Please review the changelog that comes with the package for details.

Deprecated versions:
For those running 1.3.x galleries, you are strongly recommended to upgrade to 1.4.9.  The documentation clearly describes the upgrade from 1.3.x to 1.4.9 (link), including converting any custom 1.3 themes to the improved 1.4 theme system.  Most of the popular themes have already been converted and are browseable in the demo.  Many of the mods for 1.3 have been rewritten for 1.4, with some of them being rewritten into plugins.  The new plugins system allows you to modify Coppermine without hacking the core scripts, so upgrades are very easy.

We remind you that the Coppermine 1.3 series will soon go *unsupported* and only security vulnerabilities will be addressed in this series.

Once again, please consider upgrading.  The dev team and all the supporters and contributors are working hard to make sure the latest Coppermine version is the greatest one and at the same time is completely comfortable for 1.3 users.  Test drive the current version in the demo and take the time to upgrade your 1.3.x gallery.

Asking for support:
Please do not clutter this announcement thread with individual support requests or similar, only replies that deal with the actual release are allowed - all unrelated replies will be deleted without further notice.
If you have issues with upgrading your coppermine install, post on the cpg1.4.x upgrading sub-board (after having read the docs and after having searched the board).
All announcement threads have been cluttered with individual support requests in the past and I'm not going to tolerate this any longer, so make sure that you have really understood my point before replying here: all individual support requests that get posted as a reply to this thread will be deleted and the user who posted it will be banned.

Joachim Mueller
- Coppermine project manager -
« Last Edit: August 27, 2006, 11:56:16 PM by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Maintenance release cpg1.4.9 - upgrade recommended
« Reply #1 on: August 27, 2006, 04:25:42 PM »

The security-related flaws that were fixed from cpg1.4.8 to cpg1.4.9 have not been reported as existing exploits "in the wild". Therefore, we won't post instructions how to manually update older releases by applying code changes here and there, as we know many users in the past thought that applying just one code modification made their version being fixed and safe. This is not the case: there are loads of fixes that go into releases (fixing both major and minor flaws). Don't try to manually patch your install. Do as suggested and apply the new release, then re-apply your mods (if you have any).

Joachim
« Last Edit: August 27, 2006, 11:56:44 PM by GauGau »
Logged

winne

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Maintenance release cpg1.4.9 - upgrade recommended
« Reply #2 on: October 22, 2006, 10:12:14 AM »

Dear GauGau

I want to download CPG1.4.9 but I can't because sourceforge.net was down. Can you give me other URL where I can download CPG1.4.9?

Tks,
Winne
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Maintenance release cpg1.4.9 - upgrade recommended
« Reply #3 on: October 22, 2006, 10:41:44 AM »

No. Try later, when sf.net is up again, or try using a different mirror. As suggested above, please don't reply to this announcement thread with your individual issues!
Logged
Pages: [1]   Go Up
 

Page created in 0.068 seconds with 19 queries.