Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 3 [4]   Go Down

Author Topic: [PLUGIN] File2albummover  (Read 74515 times)

0 Members and 1 Guest are viewing this topic.

Vincs

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 55
Re: [PLUGIN] File2albummover
« Reply #60 on: August 09, 2007, 11:31:07 am »

sorry I was thinking that it's not the last version.
Logged

lauriesscraps

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: [PLUGIN] File2albummover
« Reply #61 on: December 08, 2009, 04:48:04 pm »

I tried to install this but when I did, it wiped all my user pics and now there are no image files at all. So I asked my members to reupload there files and now I am trying to go in and delete the blank files but I am getting this error message "Directory 'albums/folder/lauriesscraps/' is not writable, files can't be deleted  " Does anybody know how I can fixx this and get rid of the old imgaes since there are no files linking to them?

Thanks

Lauriesscraps
www.lauriesscraps.com/gallery
Logged

lauriesscraps

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: [PLUGIN] File2albummover
« Reply #62 on: December 08, 2009, 04:49:36 pm »

I tried to install this but when I did, it wiped all my user pics and now there are no image files at all. So I asked my members to reupload their files and now I am trying to go in and delete the blank files but I am getting this error message "Directory 'albums/folder/lauriesscraps/' is not writable, files can't be deleted  " Does anybody know how I can fix this and get rid of the old images since there are no files linking to them?

Thanks

Lauriesscraps
www.lauriesscraps.com/gallery
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: [PLUGIN] File2albummover
« Reply #63 on: December 08, 2009, 04:57:49 pm »

Does anybody know how I can fixx this
Sure, there's even a section about setting permissions on file system level inside the docs that come with coppermine. I strongly doubt though that this can be caused by the plugin in itself. I guess that the permissions were wrong in the first place. Anyway, instead of asking your users to re-upload you should rather restore your files from a backup.
Logged

lauriesscraps

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: [PLUGIN] File2albummover
« Reply #64 on: December 08, 2009, 05:02:12 pm »

I don't have a back up. That is the problem. I should have, but this is a lesson learned. I have started to back it up now. I know this may be a very silly question, but I am not sure where to set those permissions. I thought I had been all through this program. Can you help me out? Thanks!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: [PLUGIN] File2albummover
« Reply #65 on: December 08, 2009, 05:10:29 pm »

Logged

lauriesscraps

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: [PLUGIN] File2albummover
« Reply #66 on: December 08, 2009, 05:24:38 pm »

ok, I changed the permissions, but I am still not able to delete the photos. I get the same message. Any other suggestions?
Logged

lauriesscraps

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: [PLUGIN] File2albummover
« Reply #67 on: December 08, 2009, 05:32:21 pm »

Coppermine documentation -> Setting permissions

I contacted my hosting support and they told me the highest it can go is 755 not 777, so I am at a loss as to what to do now. If it still needs to be set to 777, which folders? And if that doesn't work, which it hasn't so far, what else can I do?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: [PLUGIN] File2albummover
« Reply #68 on: December 08, 2009, 05:39:27 pm »

Who said that it needs to be set to 777? Read the section I refered to above already extra-carefully: in fact it says quite the opposite of what you claim - on some servers, 777 will be needed, on others 755. Wecan not tell you what is needed on your webserver setup. The most important part of the permissions section in the docs is the one highlighted in red:
If you can't figure how to set permissions properly, ask your webhost for support.
Logged

lauriesscraps

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: [PLUGIN] File2albummover
« Reply #69 on: December 08, 2009, 05:44:48 pm »

Who said that it needs to be set to 777? Read the section I refered to above already extra-carefully: in fact it says quite the opposite of what you claim - on some servers, 777 will be needed, on others 755. Wecan not tell you what is needed on your webserver setup. The most important part of the permissions section in the docs is the one highlighted in red:

I have done that and they said the highest it goes is 755. I think I read somewhere else in the forum about setting it to 777, sorry about the mix up. So They were all set to 755 and I was still not able to delete the blank files. I am on a live chat with my hosting service now, but they have no other suggestions as to why I would not be able to delete the files. Sorry for the inconvenience but any help would be great!
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4453
    • Windsurf.me
Re: [PLUGIN] File2albummover
« Reply #70 on: December 08, 2009, 06:03:03 pm »

You will need to speak to your host. It sounds like the files have a different ownership than your ftp account.

Lets explain what the 755 is. The first digit, a 7, refers to the owner of the files. The 7 means he can read, write and execure the file. The second digit refers to the group. So any member of the group that file belongs to can read or execute that file. The 5 tells me that they have no write permissions. The third digit, also a 5 refers to people who are not the file owner nor a member of a special group. In the case of a 5, they also can read or execute a file but have no write permissions.

The message you are getting shows that you are not the owner of the files as far as the file system is concerned and therefore you cannot write to them (or delete them).

So you have to ask why? In your case it appears that the files were uploaded by the script. The way your server is setup determines what user owns those files. It is obvious that your ftp account is a different user and has different rights to the files. Only your host can rectify this and they need to look at the way their system is setup or other customers will run into the same problem.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

lauriesscraps

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: [PLUGIN] File2albummover
« Reply #71 on: December 08, 2009, 06:11:22 pm »

From what I am seeing, I can not see a folder like the one it mentions in the error message present at all. As far as I know, and I could be wrong, but there has never nbeen one. They are not being created. Is this why I would be getting those messages?
Logged

lauriesscraps

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: [PLUGIN] File2albummover
« Reply #72 on: December 08, 2009, 06:15:35 pm »

when I right click on a missing image and choose "show image" I get a strange url http://lauriesscraps.com/gallery/albums/folder/NapScrappin/thumb_5_07_09.gif It includes "folder" --where did this come from? Is there a setting I can change--there never has been a folder named "folder" there as far as I know
Logged
Pages: 1 2 3 [4]   Go Up
 

Page created in 0.02 seconds with 22 queries.