Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 [2] 3   Go Down

Author Topic: Coppermine Live-Demo  (Read 349001 times)

0 Members and 1 Guest are viewing this topic.

benj_gos

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 32
    • My Myspace Page
Re: Coppermine Live-Demo
« Reply #20 on: November 06, 2006, 01:59:32 am »

The start.exe kept exiting for me after 15 seconds or so. (basically the moment i got to see the CPG)
Modifying the pms_config.ini file seems to have fixed the problem.

change from:
Code: [Select]
KeepRunningAfterBrowserClose=0to:
Code: [Select]
KeepRunningAfterBrowserClose=1
Benji
Logged

klewless

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 107
Re: Coppermine Live-Demo
« Reply #21 on: February 12, 2007, 05:51:49 am »

Hi all, especially to you, GauGau.

I really want to try this!

I looked at the galleries created by those who posted here. I have a Mac. It has iWeb which apparently has some version of Apache included. Afraid I wont be able to try the demo version.

I wish you would think of us ( photographers like Photoshop, and artsy people (like photographers and people who own Photoshop) who want to set up photo galleries like Macs best)....it would be nice.

I have a question about the demo albums I say. The images are SMALL. Can't they be bigger?

TIA
klewless
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Coppermine Live-Demo
« Reply #22 on: February 12, 2007, 10:52:19 am »

I have a Mac. It has iWeb which apparently has some version of Apache included.
The Live-Demo is Windows-only. Won't run on a MAC. Use the real coppermine package if you want to test Coppermine's features on a local webserver. Additionally, the Live-Demo goes unsupported (as in "no support at all").

I have a question about the demo albums I say. The images are SMALL. Can't they be bigger?
Yes. As I suggested: the Live-Demo goes unsupported, especially on this announcement thread. Read the coppermine documentation.

Do not clutter this thread with unrelated issues!

Logged

jult

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Coppermine Live-Demo
« Reply #23 on: April 27, 2007, 08:06:55 pm »

Sorry, a live demo is usually in an actual live situation, so online. I don't think many users will be interested in installing executables on their machines to be able to see a demo of an online gallery package. Just some realism here. (don't shoot the messenger..)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Coppermine Live-Demo
« Reply #24 on: April 28, 2007, 01:55:32 pm »

Online gallery is available on this site: it is named "demo" (link at the top of this screen). You can of course not access the admin section of the demo. That's what the "live-Demo" is meant to be used for.
If you don't need it or like it, then don't use it. ::)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Coppermine Live-Demo
« Reply #25 on: July 23, 2007, 06:33:00 pm »

Version 1.3 has just been released. Here's the list of changes:
Quote
From Live-Demo 1.2 to 1.3
-------------------
* Fixed broken images
* Fixed custom header path
* Fixed broken link to demo on the documentation page
* Removed some unwanted php.ini settings
* Added some plugins

From Live-Demo 1.1 to 1.2
-------------------
* Updated coppermine-package integrated into the live-demo from cpg1.4.8 to cpg1.4.12
* Updated documentation
* Updated server2go-version to 1.4.3 (featuring Apache 2.0.58, PHP 5.2.3, MySQL 5.0.41)
* Added a small number of user-contributed plugins to illustrate the use

From Live-Demo 1.0 to 1.1
-------------------
* updated sources to cpg1.4.9
* improved documentation

Live-Demo 1.0
-------------------
v1.0: initial release
Get it from our downloads page (link at the top of this screen).

Joachim
Logged

pipemba

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 63
Re: Coppermine Live-Demo
« Reply #26 on: July 26, 2007, 04:29:58 pm »

Code: [Select]
Parse error: syntax error, unexpected T_STRING in /home/coppermine-gallerynet/public_html/demo/cpg14x/lang/russian.php on line 66
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Coppermine Live-Demo
« Reply #27 on: July 26, 2007, 05:35:53 pm »

Not related at all to this thread. You refer to the online demonstration http://coppermine-gallery.net/Obsolete, which was affected by the bug discussed in http://forum.coppermine-gallery.net/index.php?topic=45006.msg214191#msg214191
Fixed.
Logged

recman

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Coppermine Live-Demo
« Reply #28 on: August 10, 2007, 11:39:47 am »

Hello,
to me this sounds like a great thing.

But I cant get it to work, at least not version 1.2 and 1.3. I click the start.exe, the "Coppermine Photo Gallery - Live-Demo for Windows Desktops"-page is showed and then I click "cpg1.4.x Live-Demo" which result in:

Coppermine critical error:
Unable to connect to database !
MySQL said: Unknown database 'coppermine'

I run a WinXP SP2. No other MySQL or webserver software.
Logged

Cousinjack

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Coppermine Live-Demo
« Reply #29 on: August 23, 2007, 03:42:34 pm »

Yeah I got the same problem

Coppermine critical error:
Unable to connect to database !

MySQL said: Unknown database 'coppermine'

I guess I just press ahead with the version to run my webspace's server and see how it goes
I can always change it I guess

Onen Hag Ol
Logged

opto

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: Coppermine Live-Demo
« Reply #30 on: August 24, 2007, 12:28:25 am »

Same problem here. A number of other people I know have tried versions 1.2 and 1.3 and can't get it to work either, same error.

I know that the demo goes unsupported. But if this is a common error, could someone suggest a solution for us newbies so we can use the demo for it's intended purpose?

Thanks

Demo Version 1.1 works great - thanks for providing this!
Logged

FirstDivision

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Coppermine Live-Demo
« Reply #31 on: August 29, 2007, 09:34:32 pm »

Hi,

I've been developing a .NET tool that accesses the coppermine database and image files.  Can the mySQL server and filesystem of the demo be accessed from 'outside' the demo instance?  If yes I'll have to check this out, it would be a great way to be able to get the same instance of coppermine up again and again for testing purposes. (and I could also get rid of my local instances of apache/mysql/etc).

Thanks,
Andrew
Logged

FirstDivision

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Coppermine Live-Demo
« Reply #32 on: August 30, 2007, 01:39:35 am »

Hi all,

I downloaded the same 1.3 version of the demo and also have the same "MySQL said: Unknown database 'coppermine'" error.

I was able to connect to the MySQL running on port 7188 using MySQL Administrator, and it looks like the database doesn't exist at all to me:
(http://photo.killfly.com/albums/userpics/10001/tables.JPG)

I think I'll try and get the DB from 1.2 into 1.3?  Worth a shot anyway.  At least I think I answered my question about being able to access the DB from outside the demo instance.  lol

Logged

FirstDivision

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Coppermine Live-Demo
« Reply #33 on: August 30, 2007, 02:24:35 am »

Hi all,

Ok, I think I've got it.  I put a link to what I've called Demo 1.3.1 here:
http://blog.killfly.com/

This is at the above site, but I'll post it here for completeness.  What I finally did (after a few wrong turns) was:
 - Start Demo 1.1
 - Attach MySQL Administrator to the MySQL instance, and backup the coppermine database.
 - Stop Demo 1.1
 - Start Demo 1.3
 - Attach MySQL Administrator to the MySQL instance, and restore the backup from 1.1.
 - Stop the Demo1.3
 - Zip up Demo 1.3 as 1.3.1

Ok, now back to my original project, lol.
« Last Edit: August 30, 2007, 02:40:25 am by FirstDivision »
Logged

FirstDivision

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Coppermine Live-Demo
« Reply #34 on: August 30, 2007, 03:57:20 am »

Well, I may have spoke too soon.  After trying the zip file on my laptop it didn't work...same 'Unknown Database' error.  Then I think found out something else, there a difference between the two pms_config.ini files that say something about "if the database files from the dbdir directory will be mirrored to a directory of the local machine".  This is set to zero in 1.1, and 1 in 1.2 and 1.3, probably related to the upgrade to server2go-version to 1.4.3 at Demo version 1.2.  So this is why it worked on my "dev" machine and not a "target" machine, and probably GauGau had the same issue?

Anyway, long story short I'll try to see if I can get it to work on both my machines, and then upload another zip file.

Also, anyone who's run the demos probably has a directory "C:\MyS2GApp" that gets left behind (this is where the server2go software was mirroring the MySQL databases).

Till later,
Andrew
Logged

FirstDivision

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Coppermine Live-Demo
« Reply #35 on: August 30, 2007, 04:19:15 am »

Ok,

I really think it's ok this time:  http://blog.killfly.com/index.php/2007/08/29/coppermine-demo-fixed/

-Andrew
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Coppermine Live-Demo
« Reply #36 on: September 03, 2007, 12:22:05 pm »

Thanks for spotting the error and coming up with your fix. I´ll package a new version when I return home. I guess that this is related to the caching mechanisms of server2go, as I had version 1.1 running on my testbed where I created version 1.3. I will come up with a fresh, untampered package asap.
Logged

blackgem

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: Coppermine Live-Demo
« Reply #37 on: September 17, 2007, 03:14:41 pm »

hello,

the pages on the demo look very nice; that begs the question: HOW did they get that way??

that's what a demo is for.

i'm not a computer programmer.  i'm not a web site developer.  i'm a small business owner.  i need a simple web site developing tool that does what i need it to do, with simple interfaces and easy to understand functions without a lot of jargon.  nice looking pages are fine; but your demo gives no indication about the real-world, step-by-step processes involved to build them, and no interactive way of testing out those processes.  or if it does, it's not obvious at all how - hardly a way to "provide a newbie-proof experience" for prosepective users.


and btw - i can't cut and paste on this page and your formatting buttons are disabled. 
Logged

FirstDivision

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Coppermine Live-Demo
« Reply #38 on: September 17, 2007, 04:06:06 pm »

Hi blackgem,

You might want to check out the documention and manual, that should answer most of your questions I think:
http://coppermine-gallery.net/demo/cpg14x/docs/index.htm

In particular, the Configuration and Administration section should get you started on the answers to your questions about how to get Coppermine to look the way you want.

The second place too look for answers would be the Frequently Asked Questions page:
http://coppermine-gallery.net/demo/cpg14x/docs/faq.htm

And of course the support forum itself:
http://forum.coppermine-gallery.net/index.php?board=46.0
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Coppermine Live-Demo
« Reply #39 on: September 17, 2007, 06:21:10 pm »

@blackgem: not a good idea to ask for help on the announcement thread, where we clearly mentioned that the Live-Demo goes unsupported. The docs are being included with the Live-Demo as well. Please respect board rules. Don't force us to lock down each announcement thread simply becaise people like you ignore the rules and post their individual questions there.

Thanks to FirstDivision for pointing out that reading the docs is mandatory before even being allowed to post questions.
Logged
Pages: 1 [2] 3   Go Up
 

Page created in 0.025 seconds with 21 queries.