Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Help - Added a postnuke block from pnCPG and killed site!  (Read 8752 times)

0 Members and 1 Guest are viewing this topic.

erinmac

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Help - Added a postnuke block from pnCPG and killed site!
« on: December 05, 2007, 04:43:00 pm »

Query0 failed : Table 'CopperGBO.cpg141_users' doesn't exist

I've searched and can't find this error just yet - all I did was try to add a random block to my site and it crashed everything.  Guess that's not working eh?
Logged

erinmac

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Help - Added a postnuke block from pnCPG and killed site!
« Reply #1 on: December 05, 2007, 04:53:31 pm »

I used the psak.php (postnuke swiss army knife) and switched the theme back to the default basic theme - was able to get in admin and remove the block and reset my themes.

That sucked.
Logged

casNuy

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 671
  • My other hobby
    • Nuy Community
Re: Help - Added a postnuke block from pnCPG and killed site!
« Reply #2 on: December 08, 2007, 10:33:41 am »

You are becoming an expert. I have already mentioned here on the forum that you always should start with defining a new block on the right side within Postnuke. This way you can always access the admin page and remove a block if it gives problems.
You most likely did not enter proper info when setting up the block.
Have you fixed this too by now ?

Cas
Logged

mikeymx5

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Help - Added a postnuke block from pnCPG and killed site!
« Reply #3 on: March 03, 2008, 02:29:40 pm »

OK I mess with this for a while before I found a FIX,
First to get back into Post nuke simply rename the PNCPG module folder to something else, I named mine to "PNCPG1"
Go in to postnule and disable the PNCPG block and then name the folder back.

Now you are in Postnuke again! Sucks that one block can kill postnuke but what ever?

Now to fix the real problem, for me is was a mis labled data field!
Coppermine Table Prefix ---- I had "CPG14x_" it should be just "CPG14x" yours may be a little different (this setting was the problem child for the query errors!!)
User table for Postnuke   ---- Mine is "nuke_users" adjust for you
User table for Coppermine --Mine is "cpg14x_users" again adjust this for your settings

Good luck to all!
Logged

mikeymx5

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Help - Added a postnuke block from pnCPG and killed site!
« Reply #4 on: March 03, 2008, 02:34:47 pm »

Just a side note i think that this fix needs to be stuck to the top of the forum as many people like my self have had it, and no one has posted a fix for it until now!

Considering that it can take down a site it is an important fix!
Logged

casNuy

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 671
  • My other hobby
    • Nuy Community
Re: Help - Added a postnuke block from pnCPG and killed site!
« Reply #5 on: March 03, 2008, 08:37:04 pm »

Thanks for pointing this out but if someone  is adding ablock to Postnuke, it should be configured first on the rights side so you still can access the admin section in order to disable the block. The solution has been stated several times here on the forum.

Cas
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 21 queries.