Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 3 [4] 5 6 7 8 ... 30   Go Down

Author Topic: Modpack with bridge support: PM, avatar, watermark, cropped/ sharpened thumbs...  (Read 1215775 times)

0 Members and 1 Guest are viewing this topic.

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

i've a little question about pms, the email notification system don't seems to work, i can't receive notification.. maybe the same language problem? the same for the "Display pm status info when logged in" option, any advice?

yes, you need to copy over the email stuff and the PM, buddy status info to the lang file you're using (except of course you use english)
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

opulence

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 46

Just installed it for the watermark feature and it works great!  Thanks!  :D
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

need a volunteer or two to help me test the new feature. Have run tests now for two hours myself and think it works great

custom thumb tool
what it does.. easily change thumbs for movies, audio and document files. User permissions of course get considered.
If you want you can let coppermine apply a watermark (I've already prepared some with the wording audio, movie and doc). You do not need to crop or resize on the new thumbnail on your locval box. That's done when uploading.
The 'change thumb' you can always find above the thumb in approve, edit picture (click below normal size image) and edit multiple pictures (click edit next to an album). You only will see the link when you enable it in config, when the user has the right to edit that image or when it's not an image but movie, audio, document. The new watermark files need to be placed in the folder where you've put your main watermark file. If you don't use the watermark yet follow the instructions for watermarking first. The watermark files for thumb watermarking need to be named wm_audio.png, wm_document.png and wm_movie.png. You can find my samples in the folder images/

New config settings
Files and thumbnails settings -> Enable Custom Thumbs (movie, audio, document)
Image watermarking -> Watermark custom thumbs (movie, audio, document)

the thumb watermarking is not dependent of the config setting 'Watermark Image yes|no'. That's only for normal and fullsize images

please PM me with your email addy (so I can send you the zip)
« Last Edit: March 11, 2006, 09:25:48 pm by Stramm »
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

easyjava

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 120
  • Be Tresh

Yes but your old version of kubrick doesn't work with the 1.4.4... there is many problems with the comments. And on displyimage.php the menu goes on the bottom of the page !

Code: [Select]
 
  array(Activer les miniatures personnalisées (vidéo, audio, document)', 'enable_custom_thumbs', 1),
  array('Watermarker les miniatures personnalisées (vidéo, audio, document)', 'enable_thumb_watermark', 1),


// ------------------------------------------------------------------------- //
// File changeThumb.php
// ------------------------------------------------------------------------- //

if (defined('CHANGETHUMB_PHP')) $lang_cThumb = array(
  'stats' => 'Faites une sélection',
  'available_pics' => 'Vous pouvez choisir parmis',
  'remove_thumb' => 'Supprimer la miniature actuelle',
  'remove' => 'Pour supprimer la miniature cliquez dans la case et cliquez \'Supprimer\'.',
  'title' => 'Pour le fichier portant le nom:',
  'img_name' => 'Nom de l\'image:',
  'instr' => 'Sélectionnez une image pour créer la miniature du média ci dessus (jpg/ png/ gif)',
  'deleted' => 'Miniature supprimée',
  'delete_error' => 'Impossible de supprimer la miniature',
  'no_images' => 'Vous ne pouvez changer la miniature que pour les vidéos, documents et fichiers audio',
  'error' => 'Erreur',

);
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

Okies, will have a look at the new templates when I have a free min again
... and thanks again for the translation
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

I don't see any problems with the kubrick theme... one just needs to add {LOGIN_FORM} to the template and add the friends button to the $template_sys_in theme.php... the rest is cosmetics (some css)

finished it and will post it with the mod update tomorrow or on mon
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

easyjava

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 120
  • Be Tresh

Thank you very much  ;)
Logged

gringohh

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

hey Stramm, i{ve installed your mod, and now i can{t batch upload, after i select the album i want the pics to go in, the nex screen comes up and insted of any icons like OK, and the rest of them, i get a link that says, click for details or click for reload, when i click there i get an internal server error, how do i fix this? didn't have a problem before applying the mod.

and my next question, is it all posible to just apply the watermark mod, and how would i do that?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

reupload everything and run update.php again. Looks like some messed up files. Make sure you overwrite the files. Don't resume

And no, it was to much work to keep the single mods up to date ... so I just pet the modpack
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

Bierfreund

  • Coppermine newbie
  • Offline Offline
  • Posts: 1

Has someone already modified the german language file german.php for the modpack? I have no php skills and can't do it myself.
Logged

easyjava

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 120
  • Be Tresh

Thank you very much Stramm... but update this file... there was an error with the : "é"
Logged

gringohh

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

reupload everything and run update.php again. Looks like some messed up files. Make sure you overwrite the files. Don't resume

And no, it was to much work to keep the single mods up to date ... so I just pet the modpack

reupload the modpack?? or the whole coppermine installation and then the modpack?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

reupping the modpack should do
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

Quote
Has someone already modified the german language file german.php for the modpack? I have no php skills and can't do it myself.
no volunteer so far

Quote
Thank you very much Stramm... but update this file... there was an error with the : "é"
k, will do, thanks ;)
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

gringohh

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

reupping the modpack should do

yeah i just did that, still have the same problem, can't batch upload
Logged

gringohh

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

it's very wierd too because the files are created, when i look at my folder on my ftp, i have the thumb files, mini thumb files, everything is created but not available in the gallery very wierd, doesn't work when i upload one by one either
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

link??
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

gringohh

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

i sent u a pm
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

http upload works,
watermark+
sharpen+
crop+
batch upload+

hmm, can you be more specific with your problem?
and you don't use the latest modpack version, actual it's 1.4.4 bridge v2 (whether or not you use a bridge)

edit: ahh.. I see, the thumbs and images don't show up... that's permission problems as it looks. Chmod your batch add folder 777. If that doesn't help then the files too
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

gringohh

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

very wierd, thank you
 ???
Logged
Pages: 1 2 3 [4] 5 6 7 8 ... 30   Go Up
 

Page created in 0.021 seconds with 21 queries.