Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 [2] 3 4 5 6 ... 30   Go Down

Author Topic: Modpack with bridge support: PM, avatar, watermark, cropped/ sharpened thumbs...  (Read 1212295 times)

0 Members and 1 Guest are viewing this topic.

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

Hi! This is the very best Mod i've ever seen for coppermine! thanks!

But i have e little problem with the Watermark option: If I have checked the option "Both" in "Which files to watermark" I have the Watermark only on the resized, but not on the orignial size pic. Could you help me?

I've heared that once before and it was a temp thing. I guess an overloaded server or similar. If you can post an URL and maybe pm me a testuser account I can have a look
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

What edits do I have to make to my Eyeball theme to make it compatible with your mod pack?

most themes are compatible by default. You only need to add the tag {LOGIN_FORM} in template.html where the loginform and the PM/ buddy info should appeare
And you need to copy some css from classic theme to eyeball theme and adapt colors (that's css necessary especially for PM and buddy system)  -- starting from .alt1, .alt1Active    to     .smallfont
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

Hi Stramm. I was wondering, I would like to for my intermediate and fullsize images to have different watermarks.
How hard would it be to copy the code for the watermarking. Could you give me a hint in the right direction where i should look ?


you've to functions in picmgmnt.inc.php
add_picture and resize_image
resize_image... change it to eg
Code: [Select]
resize_image($src_file, $dest_file, $new_size, $method, $thumb_use, $watermark="false", $sharpen=0,fullsize_wm="false")fullsize_wm="false" is new...

if false then the watermark image stays $CONFIG['watermark_file'] else you change it to your desired one
here for GD2:
Code: [Select]
$logoImage = ImageCreateFromPNG($CONFIG['watermark_file']);
add_picture: needs changes where it checks if the orig needs a watermark and calls the resize_image function... add fullsize_wm="true"
Code: [Select]
if (!resize_image($work_image, $image, $max_size_size, $CONFIG['thumb_method'], $resize_method, 'true',,'true'))
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

what modifications do i need to do to the theme to show Mini thumbs in film strips ?

thanks for the wonderfull mod :)

ahhh... nice idea ;)
copy over the function theme_display_film_strip from themes/sample/theme.php to the theme.php you're using
find in that theme....
Code: [Select]
    foreach($thumb_list as $thumb) {
        $i++;
and below add
Code: [Select]
if ($CONFIG['enable_mini_thumbs']){
        $thumb['image']=preg_replace('/'.$CONFIG['thumb_pfx'].'/',$CONFIG['mini_pfx'],$thumb['image']);
        $thumb['image']=preg_replace('/height="[^"]*"/','height="'.$CONFIG['mini_thumb_height'].'"',$thumb['image']);
        $thumb['image']=preg_replace('/width="[^"]*"/','width="'.$CONFIG['mini_thumb_width'].'"',$thumb['image']);
}
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

n3n

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 173

Ok tnx alot man, gonna try to fix it, if it works ill post it for others.
Logged

free

  • Coppermine newbie
  • Offline Offline
  • Posts: 3

Hello Stramm
I found the error: if I insert the pictures with "Upload file", the Watermark is on both pictures. If I upload the pictures per FTP and insert the pictures with the function "Batch add files", the Watermark ist only on one picture (the original pic isn't watermarked). Is there a possibility to fix this little error?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

Hello Stramm
I found the error: if I insert the pictures with "Upload file", the Watermark is on both pictures. If I upload the pictures per FTP and insert the pictures with the function "Batch add files", the Watermark ist only on one picture (the original pic isn't watermarked). Is there a possibility to fix this little error?

ther orig_ picture (the one with the prefix orig_) never gets watermarked. It's the backup file. The one without any prefix is the fullsized image. I've tried with and without batchadd, with and without resize... I can't reproduce your problems.
Maybe you can give me some more info... GD2, ImageMagick...size settings (pixel, kb) etc
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

farhan

  • Coppermine newbie
  • Offline Offline
  • Posts: 17

thanks a lot Stramm :)
Logged

coookie

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

Hi Stramm,
thank you for sharing this mod! I've installed it on my v1.4.4 gallery and it works perfectly, except now anonymous users can't see their comments anymore. My permissions are set so that no one has to register to view the gallery and guests can post and read comments. Is there any way I can keep it that way but make the comments show up again for everyone to see? ???
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

Hi Stramm,
thank you for sharing this mod! I've installed it on my v1.4.4 gallery and it works perfectly, except now anonymous users can't see their comments anymore. My permissions are set so that no one has to register to view the gallery and guests can post and read comments. Is there any way I can keep it that way but make the comments show up again for everyone to see? ???

yup, lil bug related to bridge compatibility... very easy to fix
in bridge/udb_base.inc.php find the function get_comments (at bottom)
in the sql statement find INNER JOIN and replace it with LEFT JOIN
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

coookie

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

It worked! Thank you so much  :D
Logged

Thierry

  • Coppermine newbie
  • Offline Offline
  • Posts: 10

Hi,

It seems to be a great modpack!

But in my conf, when I want to activate something (ie pms), it tells me that the conf has been updated, but it's not saved, so.. i can't enable new features, any idea why?

And a second question about my theme. I'm using "rainy day" theme, and usually the numbers of image views is under the image, in the same place as comments. And after the update, the number of views is right to the image, so.. it doesn't look aligned as u can see in the attachement, any advice?

Thank you in advance!
« Last Edit: March 07, 2006, 03:42:15 am by Thierry »
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 6006

if the config settings don't get saved then usually the SQl hasn't been updated entirely. Try to run update.php again

You're describing a new feature here... read that part in the documentation (post 2) - 'Move info from below the thumb to the right of it (default off)' and view the demo how it looks in action http://stramm.st.funpic.org/
Logged
my CPG sandbox: Version 1.4.18 with modpack running my Tentacle theme:
http://stramm.st.funpic.org/

easyjava

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 120
  • Be Tresh

Hello

When i want to open a picture i have an error :
Code: [Select]
While executing query "SELECT msg_id, msg_author, msg_body, UNIX_TIMESTAMP(msg_date) AS msg_date, author_id, author_md5_id, msg_raw_ip, msg_hdr_ip, pid, avatar_url FROM cpg143_comments WHERE pid='38' ORDER BY msg_id ASC" on 0

mySQL error: Unknown column 'avatar_url' in 'field list'

Can you help me ?

Code: [Select]
USER:
------------------
Array
(
    [ID] => xxx
    [am] => 1
    [lang] => french
    [liv] => Array
        (
            [0] => 39
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => easyjava
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg143_filetypes; (0s)
    [1] => select * from cpg143_plugins order by priority asc; (0s)
    [2] => delete from `treshch`.cpg143_sessions where time<1141764134 and remember=0; (0s)
    [3] => delete from `treshch`.cpg143_sessions where time<1140558134; (0s)
    [4] => select user_id from `treshch`.cpg143_sessions where session_id=md5("xxx"); (0s)
    [5] => select user_id as id, user_password as password from `treshch`.cpg143_users where user_id=1 (0s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.avatar_url AS avatar_url, u.enable_admin_email AS notify, u.auto_subscribe_post AS auto_subscribe_post, u.auto_subscribe_comment AS auto_subscribe_comment, u.user_group+100 AS group_id FROM `treshch`.cpg143_users AS u INNER JOIN `treshch`.cpg143_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
    [7] => SELECT user_group_list FROM `treshch`.cpg143_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg143_usergroups WHERE group_id in (1) (0s)
    [9] => SELECT group_name FROM  cpg143_usergroups WHERE group_id= 1 (0s)
    [10] => update `treshch`.cpg143_sessions set time='1141767734' where session_id=md5(xxx); (0s)
    [11] => SELECT user_favpics FROM cpg143_favpics WHERE user_id = 1 (0s)
    [12] => DELETE FROM cpg143_banned WHERE expiry < '2006-03-07 21:42:14' (0s)
    [13] => SELECT * FROM cpg143_banned WHERE (ip_addr='85.218.27.85' OR ip_addr='85.218.27.85' OR user_id=1) AND brute_force=0 (0s)
    [14] => SELECT title,keyword from cpg143_albums WHERE aid='1' (0s)
    [15] => SELECT COUNT(*) from cpg143_pictures WHERE ((aid='1'  ) )   (0s)
    [16] => SELECT * from cpg143_pictures WHERE ((aid='1'  ) )   ORDER BY pid DESC  LIMIT 1 ,1 (0.001s)
    [17] => SELECT title, comments, votes, category, aid FROM cpg143_albums WHERE aid='1' LIMIT 1 (0s)
    [18] => SELECT msg_id, msg_author, msg_body, UNIX_TIMESTAMP(msg_date) AS msg_date, author_id, author_md5_id, msg_raw_ip, msg_hdr_ip, pid, avatar_url FROM cpg143_comments WHERE pid='38' ORDER BY msg_id ASC (0s)
)

==========================
GET :
------------------
Array
(
    [album] => 1
    [pos] => 1
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 4.4.2 - OK
------------------
mySQL version: 4.1.12-log
------------------
Coppermine version: 1.4.4(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.28 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.1.12
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /tmp/mysql.sock
MYSQL_INCLUDE -I/opt/mysql/include/mysql
MYSQL_LIBS -L/opt/mysql/lib/mysql -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.1.4
Linked Version 1.1.4
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | set_time_limit,passthru,exec,system,popen,shell_exec,proc_open | set_time_limit,passthru,exec,system,popen,shell_exec,proc_open
file_uploads | On | On
include_path | .:/opt/php/lib/php | .:/opt/php/lib/php
open_basedir | /home/www/987cf041e7728844b29fdfd59e89e6c0/:/tmp | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail_r -t -i -fwebmaster@tam.ch | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 10 | 10
max_input_time | 60 | 60
upload_max_filesize | 48M | 48M
post_max_size | 48M | 48M
==========================
Page generated in 0.147 seconds - 19 queries in 0.001 seconds - Album set : ; Meta set: ;
Logged

Thierry

  • Coppermine newbie
  • Offline Offline
  • Posts: 10

You're describing a new feature here... read that part in the documentation (post 2) - 'Move info from below the thumb to the right of it (default off)' and view the demo how it looks in action http://stramm.st.funpic.org/

Yeah I found it thanks. But still can't update configuration..

if the config settings don't get saved then usually the SQl hasn't been updated entirely. Try to run update.php again

I've tried to update again, it seems to be ok, I've some information "OK" or "Already done", Here is a link of the screenshot of the result of the update, can you check it please? It still don't work.. I can save some information (like the displaying of language list), but the most of the new configuration (modpack) can't be changed..

Think I need some help! :p
Thank you in advance.

« Last Edit: March 08, 2006, 02:09:35 am by Thierry »
Logged

xsportseeker

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 37
    • Aoi Sora Forum

I'm having some trouble installing it, and after browsing through the code a little, I guess it's the same problem as my french friend one post up.
Error is:
Code: [Select]
Template error
Failed to find block 'my_friends'(#(<!-- BEGIN my_friends -->)(.*?)(<!-- END my_friends -->)#s) in :
(yadda yadda)

I guess it happens because some variables from the mod, were added on lang/english.php only.
So, I made a complete comparison check with original and modded version, and came up with the stuff people will have to modify on their own lang file.
For instance, mine is lang/portuguese.php.
Doing it ancient phpBB MOD style...
Here goes: (anything goes wrong, feel free to warn me, or change this list)
*also note the variables contents were not translated, but you can translate it if you want to.

Had to put it on a text file because there were far more changes than I expected... enjoy it!

***NOTES:  The text file was supposed to be a post... so, please, forget all the [_CODE] and [_/CODE]... erm... codes. They were supposed to be bbCodes for making things clearer on the post.
Also, notice that those are comparisons from the original lang/english.php Coppermine 1.4.4 file, with the one suplied with this MOD.
Still, for people intending to apply those changes directly on their specific language files, just search for the strings WITHOUT variables contents.
For instance, on this part:
After:
Code: [Select]
  'cookie_prefix_explanation' => 'this has to be your BBS\'s cookie name',

Instead of looking for the whole line... search on your language file only for:
  'cookie_prefix_explanation' =>

You'll have to do this because the rest of the line is probably already translated to your language.

That's it. I wouldn't have to explain all this if I planned what I was doing better.... hope you get it anyways. XD
« Last Edit: March 08, 2006, 03:32:47 am by xsportseeker »
Logged

xsportseeker

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 37
    • Aoi Sora Forum

More notes:

On admin config menu, if there are any translations fully made on this part, it may become impossible to tell where to make some changes I pointed out... I would have to think on another way to show were the changes were made. Sorry about that... portuguese version does not translate the admin config menu.

Finaly, I also noticed most changes doesn't really need to be done. If coppermine doesn't find the translation on a specific language, it will search for it on english.php lang file.
Logged

xsportseeker

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 37
    • Aoi Sora Forum

MWAAAAAAAAAAAAAAAAA HA HA HA HA HA

I just did loads of work for nothing. o__O

The error I had is in fact, because I'm using a different theme (hope I'm not wrong again).

Anyways, everything I just wrote is still useful if you want to translate mod stuff to your language.
Logged

xsportseeker

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 37
    • Aoi Sora Forum

To those having problems with templates (theme) other than those covered by Stramm's mod, I made 2 text files that point out changes made in the CLASSIC theme.
Main changes are in files /themes/classic/style.css and /themes/classic/template.html

With this, it's probably not too hard to make some adaptations to your own template files to make it work with Stramm's MOD.
Logged

Thierry

  • Coppermine newbie
  • Offline Offline
  • Posts: 10

MWAAAAAAAAAAAAAAAAA HA HA HA HA HA

I just did loads of work for nothing. o__O


You're wrong ! U save me.. lol

All's now working fine! Big thanks xportseeker ;)
Logged
Pages: 1 [2] 3 4 5 6 ... 30   Go Up
 

Page created in 0.025 seconds with 20 queries.