Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG  (Read 54582 times)

0 Members and 1 Guest are viewing this topic.

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« on: January 18, 2006, 07:26:14 am »

Digibug Pro Photo Commerce allows you to sell photos and generate profits from your Coppermine Photo Gallery.  The service is free* and set-up takes about 10 minutes.

Key features of Digibug 

- you set the prices and choose the products (over 110 products to choose from)
- low wholesale prices allow you to control the profit you receive from images ordered off your Coppermine site
- you control the branding of the shopping cart, email notifications and shipping docs
- we pay you monthly (checks in the U.S., PayPal outside U.S.). 
- we ship to the world (from the U.S. currently)
- multiple price lists are supported (different pricing for different albums, etc.). 

Included in this post is the plug-in for CPG 1.4  Installation and configuration directions are in the README.txt in the docs directory of the included tar file.  If you have questions ask them here in this thread and I will respond withing a reasonable amount of time.  The plugin is released under the GPL.  Contributions, suggestions are welcome.

For more details on the Digibug API, see http://www.digibug.com/digibugapi/.  To set up your free Digibug account, or to learn more, please visit. http://www.digibug.com.

* there is no charge to create an account on Digibug, though we do deduct a small processing fee from the profits you generate on each order (see Digibug.com for more details).
« Last Edit: February 10, 2006, 09:12:53 am by GauGau »
Logged

TranzNDance

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Female
  • Posts: 6148
    • Take Thu! Gallery

Thank you for the contribution. :) Is there a particular reason why you ask people to ask for help via PM? We prefer people ask questions in the forums so that anyone can benefit from the Q&A.

Thanks.
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19

Thank you for the contribution. :) Is there a particular reason why you ask people to ask for help via PM? We prefer people ask questions in the forums so that anyone can benefit from the Q&A.

Thanks.

Only because it would notify me of questions, but you are right the forums are the right place for it.  I have edited my initial message, and will check daily for questions.

Logged

TranzNDance

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Female
  • Posts: 6148
    • Take Thu! Gallery

You can click the NOTIFY button for this thread so that you will receive notifications when there are new messages. :) Oh, I just read your correction. People shouldn't post questions anywhere else in the forums so you don't have to check the forums aside from this thread.
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19

You can click the NOTIFY button for this thread so that you will receive notifications when there are new messages. :) Oh, I just read your correction. People shouldn't post questions anywhere else in the forums so you don't have to check the forums aside from this thread.

OK, edited and Notified checked.  I am now ready to answer questions. :-D
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
.3.1 beta. Major Bug Fixes.
« Reply #5 on: January 19, 2006, 10:47:32 pm »

There were a couple bugs preset in the .3.1 version.  We had a form name change that broke the form that submited to  orders to Digibug  this prevented your company id for getting credit for the order.  If you have installed version .3 beta you need to update.  We have added some error correction on the server side that should prevent orders from going through with the .3 version.

.3 also did not work correctly in subdirectorys, so if your gallery was installed in /gallery off of your domain, it would not have worked at all.  This is now fixed and coppermine installations that are in a subdirectory can now use our plugin.

Sessions are required to use our plugin.  If auto_start session was not = 1 then the plugin failed to work.  We have added code to start sessions.  It should suppress errors regarding session starting if you have problems with this please let us know so we can work out a resolution.

The old file has been removed from the top post, and the new file has been uploaded.
Logged

desertcities

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #6 on: February 07, 2006, 07:14:05 am »

I cannot seem to get this plugin to work. 

It installed correctly; setup my account at Digibug, and adjusted the:
$digibugCompanyId=452;
$digibugEventId=1190;

But does not work.  Why?

I do see the +/Cart under each thumbnail (why not in full size mode too?).  However, when you click on any thumbnail (using Rainy Day template) nothing happens except a browser error.  Also, under each thumbnail the +/Cart link is going to http://www.desertcities.net/galleries/index.php# which cannot be found.

http://www.desertcities.net/galleries

A cool idea.  Not many downloads here, I hope I'm not posting in wrong section.

Mark
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #7 on: February 07, 2006, 04:57:49 pm »

Hrm....  Let me change my theme to this theme and see if I can solve the problem.   I will be addign a [+cart] to the full size page.  I just hadn't thought iof it at the time of initial release.  I'll get back to you with a solution to this.
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #8 on: February 07, 2006, 06:46:14 pm »

I cannot seem to get this plugin to work. 

It installed correctly; setup my account at Digibug, and adjusted the:
$digibugCompanyId=452;
$digibugEventId=1190;

But does not work.  Why?

I do see the +/Cart under each thumbnail (why not in full size mode too?).  However, when you click on any thumbnail (using Rainy Day template) nothing happens except a browser error.  Also, under each thumbnail the +/Cart link is going to http://www.desertcities.net/galleries/index.php# which cannot be found.

http://www.desertcities.net/galleries

A cool idea.  Not many downloads here, I hope I'm not posting in wrong section.

Mark


Mark,

Did you edit any of the javascript or php code in the module?  I noticed the [ ] are missing from around the + Cart.  If you did then you may have broken some of the code.  I changed to the Rainy Day theme on my test site, and it worked fine by default.  Just trying to figure out what's different.

Thanks,
James
Logged

desertcities

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #9 on: February 07, 2006, 10:26:29 pm »

Hi James,

No, I did not change any other code. 

In fact, I don't have any other plug-ins installed except for the Digibug Pro. 

Would it help if I PMed you my Coppermine Login info? 

I shall also try to uninstall and re-install too.  Maybe there was something wrong with my Rainy Day template already and I never knew about it?

Thank you very much James.

Mark
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #10 on: February 07, 2006, 10:31:56 pm »

I cannot seem to get this plugin to work. 

It installed correctly; setup my account at Digibug, and adjusted the:
$digibugCompanyId=452;
$digibugEventId=1190;

But does not work.  Why?

http://www.desertcities.net/galleries


Hi Mark,

I found what I think is the problem.  Part of our plugin calls for a CSS file that we keep in the plugin directory.  When we call it it takes your gallery url that you have set in your site config and pre-appends it to the path where our CSS file is.   That URL is

http://desertcities.net/galleries/plugins/Digibug4CPG/includes/DigibugAPI.css

If you click on the above URL you will notice that your website redirects to a 404 error (ie the link below)

http://www.desertcities.netgalleries/plugins/Digibug4CPG/includes/DigibugAPI.css

You'll notice that the URL is broken.  There is no / between "net" and "galleries"  So you have some kind of redirect from desertcities.net to www.desertcities.net that does not include the trailing slash when it rewrites URLs and that is breaking our module.  To fix this, please modify your redirect to include trailing slash.

This should rectify your problem.

James
Logged

desertcities

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #11 on: February 08, 2006, 11:23:36 am »

Hi Mark,

I found what I think is the problem.  Part of our plugin calls for a CSS file that we keep in the plugin directory.  When we call it it takes your gallery url that you have set in your site config and pre-appends it to the path where our CSS file is.   That URL is

http://desertcities.net/galleries/plugins/Digibug4CPG/includes/DigibugAPI.css

If you click on the above URL you will notice that your website redirects to a 404 error (ie the link below)

http://www.desertcities.netgalleries/plugins/Digibug4CPG/includes/DigibugAPI.css

You'll notice that the URL is broken.  There is no / between "net" and "galleries"  So you have some kind of redirect from desertcities.net to www.desertcities.net that does not include the trailing slash when it rewrites URLs and that is breaking our module.  To fix this, please modify your redirect to include trailing slash.

This should rectify your problem.

James

Hi James,

I corrected the redirect problem.  Thank you very much for pointing that out to me.  I have noticed the CSS is working now.

However, after clicking on any image I'm still not getting any action and nothing is being saved to the cart.

When I click on any photo I get the following: http://www.desertcities.net/galleries/index.php#

I hate to keep bugging you about this.  I would really like to see this program working as I have another site of my photography works.

Sincerely,

Mark
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #12 on: February 08, 2006, 04:02:21 pm »

Hi James,

I corrected the redirect problem.  Thank you very much for pointing that out to me.  I have noticed the CSS is working now.

However, after clicking on any image I'm still not getting any action and nothing is being saved to the cart.

When I click on any photo I get the following: http://www.desertcities.net/galleries/index.php#

I hate to keep bugging you about this.  I would really like to see this program working as I have another site of my photography works.

Sincerely,

Mark

Hi Mark,

Ok, so after digging around, I found this.  I was in Firefox with the javascript console open looking for possible javascript errors and I got this error when I loaded your page.  "Error: uncaught exception: Permission denied to call method XMLHttpRequest.open".  I did a google search and found this error is cause by cross-domain scripting with XMLHttpRequest.  In your config for Coppermine under "General settings" --> "URL of your coppermine gallery folder (no 'index.php' or similar at the end)"  you have http://desertcities.net/galleries/ but your redirect sends it to http://www.desertcities.net/galleries/ which is where your site redirects too.  We pull from this config setting to set the path to our files so our XMLHttpRequests for our AJAX code can find the correct path to the files that return the needed XML for the plugin.  Part of the security for AJAX is to disallow "cross-domain" scripting, so we are making our calls from http://www.desertcities.net/galleries/ to http://desertcities.net/  causing the security error in the javascript.  So to resolve this the config should be set to what the final domain of the server really is which is " http://www.desertcities.net/galleries/".  If this is a problem we can try to find a work around.

James



Logged

desertcities

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #13 on: February 08, 2006, 11:55:48 pm »

Hi James,

I adjusted the config setting and added the www.  It seems to be working now.

Is there any way to make the text link 'x images in the cart' and 'check out' into the color white instead of the dark blue for this template?  Not sure where to change that code though.

Also, in the future will you have it so we could pick and chose which photo albums we might want to sell from and to place the link on the larger photos?  And, I gather a short description would be wise telling users they can buy the photo while viewing the thumbnail instead of guessing what the +/add cart button was for.

Thank you very much for your time.

Mark
« Last Edit: February 09, 2006, 12:25:19 am by desertcities »
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #14 on: February 09, 2006, 12:55:50 am »

Hi James,

I adjusted the config setting and added the www.  It seems to be working now.

Is there any way to make the text link 'x images in the cart' and 'check out' into the color white instead of the dark blue for this template?  Not sure where to change that code though.

Also, in the future will you have it so we could pick and chose which photo albums we might want to sell from and to place the link on the larger photos?  And, I gather a short description would be wise telling users they can buy the photo while viewing the thumbnail instead of guessing what the +/add cart button was for.

Thank you very much for your time.

Mark

Hi Mark,

Glad to see that you were able to get it working. I just looked at the code and see that I hadn't defined ID's or classes for those.  I will do that  and try to add the button the the image page.  There are some limitations on what I can do, as I am limited to where filters are placed within the CPG code.  I am not sure if there is a filter that I can use for the image page, but there might be.  The filter hooks aren't really documented to well. Hopefully the CPG team are working on that.   Once I have Ids defined I'll post the new version here and then post instructions on where to edit the CSS.

James
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
Digibug4CPG v0.3.2 beta.
« Reply #15 on: February 09, 2006, 09:30:01 pm »

Hi Everyone,

I have made a quick change to the Digibug4CPG plugin, to allow you to change the colors of the cart and checkout links so it can match your theme.  inside the includes directory in the Digibug4CPG plugin directory is a DigibugAPI.css file.  It contains 2 new class definitions digibug-sub-menu and digibug-sub-menu:hover  using standard CSS coding you can change the behavior of these 2 hyperlinks.

There have been many requests for having the add/remove button added to the image page.  This functionality will be in the next release 0.3.3 which will be out before the end of the month.

James
Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
Vacation: Feb 10th through Feb 21 2005
« Reply #16 on: February 09, 2006, 09:31:21 pm »

I will be away on vacation from the 10th to the 21st.  If you send me a PM or a question to the board, I will respond when I return.

Thanks, and have a great week.

James
Logged

desertcities

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #17 on: February 10, 2006, 06:56:43 am »

James,

I modified the css submenus changing link color and roll over effect and now when I go to add an item to my cart, it does not add.  Not sure what's going on.

I will uninstall this plugin until you get back.

Mark
Logged

Tsumik

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #18 on: February 16, 2006, 08:29:11 pm »

I have installed this plug in and it seems to work fine in the modified hardwire theme I'm currently using. I also have it setup with a IPB Forum bridge. I do have a couple questions:

1) Will the additional button be placed on the Full size image or the secondary image that's larger then the thumbnail? I have it setup where the user can only see the thumbnail and the intermediate image not the full size image.

2) Which image is used for printing? The original full size image or the itermediate image which shows after clicking the thumbnail?

3) Any chance we'll be able to move the cart counter and checkout link to a different spot by use of a tag or possibly even an admin tool?

4) I currently have the option that one can not view an image unless they are signed up as a registared user but can view thumbnails. Any chance we can have the plugin not active if the user is nott signed in as to prevent guest users from purchasing prints.

5) Do you work for digibug or just someone who decided to create an API for coppermine? (just wondering so I know if I should ask you or them questions about billing, customer service, returns etc)

6) Not really a question but I'm looking forward to the remove photo option in the cart as it's a pretty key piece I'd like to have before allowing my gallery out to the public again.

Hope to hear back from you soon as I've got a couple thousand people waiting for me to put the gallery back online! =)

Logged

thenetimp

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 19
Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
« Reply #19 on: February 22, 2006, 04:49:39 am »

I have installed this plug in and it seems to work fine in the modified hardwire theme I'm currently using. I also have it setup with a IPB Forum bridge. I do have a couple questions:

1.) It will be on the secondary image, and thumbnail, not the full res image.

2) The full resollution image is sent.

3)  I plan on revisiting these links, as it's not very customizable right now.

4)  I can see about adding this as a config option, I see no reason why it can't be added.

5) I work for Digibug.  I do not always have the answer for billing, customers service, or returns, those questions are best sent to our customer service department.  I am relatively sure it's  customerservice@digibug.com  If not yell at me, and I'll get the right address.

6) I will discuss this with people tomorrow, I don't think we had planned for a remove photo option in the cart as all you need to do is zero out the product and it doesn't get ordered, but I can see why you may want it.

Logged
Pages: [1] 2   Go Up
 

Page created in 0.024 seconds with 22 queries.