Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Cannot login as admin or user.  (Read 3506 times)

0 Members and 1 Guest are viewing this topic.

kirstyturner321

  • Coppermine newbie
  • Offline Offline
  • Gender: Female
  • Posts: 1
    • JonBenet-Ramsey.com
Cannot login as admin or user.
« on: December 01, 2005, 11:26:56 am »

Hi,
I recently upgraded from coppermine 1.3 to cpg 1.4. The upgrade was successfull and the gallery worked fine, it would allow me to login, ect.
Then i went to bridge with invision board (i did this with the previous version i hade also and it worked) and after i went through the bridging wizard i went to resync my member groups. After i did all this i logged out and logged back in and got taken to the login page of my forums, but it dident redirect me back to the galleries. Since somthing wasen't working, i went back to the gallery to turn the bridging off, but it wouldent let me log in. So i did the bridgemgr.php and turned the bridging off. But i still cannot log into my admin account, nor a users account either. I cannot get inside whatsoever.
It takes my admin username and password ok, but then redirects me back to the main page as a guest?
I have no idea whats going on, i cant even create a test account for you guys to check it out since i cant log in, or it wont let anyone log in anyway.

I did try a couple of other things, like change theme from my custom made one to a cpg1.4 theme. I even tryed re-uploading the appropriate files and ran the update.php again, but still nothing?
Please help!!
Thanks in advance.
p.s- My gallery url is http://jonbenet-ramsey.com/gallery
Logged
~~*Kirsty*~~

Nibbler

  • Guest
Re: Cannot login as admin or user.
« Reply #1 on: December 02, 2005, 01:14:09 am »

Edit groupmgr.php, and temporarily comment out this line

Code: [Select]
if (!GALLERY_ADMIN_MODE) cpg_die(ERROR, $lang_errors['access_denied'], __FILE__, __LINE__);
ie

Code: [Select]
// if (!GALLERY_ADMIN_MODE) cpg_die(ERROR, $lang_errors['access_denied'], __FILE__, __LINE__);
Then go to groupmgr.php in your browser. That will allow you to resync the groups. You should then be able to login.
Logged

foreverfan

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Cannot login as admin or user.
« Reply #2 on: December 26, 2005, 05:05:28 pm »

i had the same problem with bridging with Mambo, it worked correctly for one day, the next day i couldn't login anymore,  that happened when i didn;t find the upload files and desided to undo the brdiging to see if that helped

Topic Summary
Posted on: December 02, 2005, 01:14:09 AMPosted by: Nibbler 
Insert Quote
Edit groupmgr.php, and temporarily comment out this line


Code:
if (!GALLERY_ADMIN_MODE) cpg_die(ERROR, $lang_errors['access_denied'], __FILE__, __LINE__);
ie


Code:
// if (!GALLERY_ADMIN_MODE) cpg_die(ERROR, $lang_errors['access_denied'], __FILE__, __LINE__);


resynced my groupmgr.php. I can't bridge with mambo however then because that still doesnt work.
i deleted everything and only used the backup i made from the files stated in the information at your site.
 
Logged

JohnON

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Cannot login as admin or user.
« Reply #3 on: December 21, 2016, 02:13:46 pm »

I ran into a similar issue where my Registered Users got the message "Welcome Guest"after logging in. They did not have their assigned permissions.  I played around and found this fixes it:
Change their group to Administrators.
Edit them again.  This time change their group to Registered, but leave both of the check boxes under the REGISTERED box empty.
That did it for me.
John from Ontario
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 21 queries.