Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Vbulletin Bridge Issue (cookie prefix in bridgemgr.php)  (Read 12367 times)

0 Members and 1 Guest are viewing this topic.

Karri

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Gender: Female
  • Posts: 44
    • The Fuselage
Vbulletin Bridge Issue (cookie prefix in bridgemgr.php)
« on: October 26, 2004, 07:12:06 am »

I am loving the new bridge manager to set up my bridge.  I did have one problem with it though.  I use vbulletin and the bridge manager did not give me the option to input my cookie prefix.  I didn't realize that vbulletin had even set a default cookie prefix until I read http://forum.coppermine-gallery.net/index.php?topic=9130.msg44306#msg44306 since I did not see a cookie prefix that matched the one in my config file anywhere in the admin panel.  I told the bridge manager to unhide the unused fields and saw where it does have the option for a cookie prefix but it does not let me change it.  Once I went into phpmyadmin and changed it manually the bridge worked perfectly.
« Last Edit: October 27, 2004, 05:52:41 am by GauGau »
Logged
Thanks,
Karri

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Vbulletin Bridge Issue
« Reply #1 on: October 26, 2004, 07:52:43 am »

Thanks for the report. To fix this, edit bridgemgr.php, find
Code: [Select]
$default_bridge_data['vbulletin30'] = array(
  'full_name' => 'vBulletin 3.0',
  'short_name' => 'vbulletin30',
  'support_url' => 'http://www.vbulletin.com/',
  'license_number_default' => 'xxxxxxxx',
  'license_number_used' => 'mandatory,not_empty',
  'db_database_name_default' => 'forum',
  'db_database_name_used' => 'mandatory,not_empty',
  'db_hostname_default' => 'localhost',
  'db_hostname_used' => 'mandatory,not_empty',
  'db_username_default' => '',
  'db_username_used' => 'mandatory,not_empty',
  'db_password_default' => '',
  'db_password_used' => 'password',
  'relative_path_of_forum_from_webroot_default' => '/vbulletin3/',
  'relative_path_of_forum_from_webroot_used' => 'mandatory,not_empty',
  'user_table_default' => 'user',
  'user_table_used' => 'mandatory,not_empty',
  'session_table_default' => 'session',
  'session_table_used' => 'mandatory,not_empty',
  'group_table_default' => 'usergroup',
  'group_table_used' => 'mandatory,not_empty',
  'use_standard_groups_default' => '1',
  'use_standard_groups_used' => 'mandatory,not_empty',
  'validating_group_default' => '3',
  'validating_group_used' => 'optional',
  'guest_group_default' => '1',
  'guest_group_used' => 'optional',
  'member_group_default' => '2',
  'member_group_used' => 'optional',
  'admin_group_default' => '6',
  'admin_group_used' => 'optional',
  'create_redir_file_content' => '<?php\necho\'Hello World\';\n?>\n',
  'create_redir_file_location' => '{BBS_LOCATION}/cpg_redir.php',
  'create_redir_file_action' => 'display,write',
);
and replace with
Code: [Select]
$default_bridge_data['vbulletin30'] = array(
  'full_name' => 'vBulletin 3.0',
  'short_name' => 'vbulletin30',
  'support_url' => 'http://www.vbulletin.com/',
  'license_number_default' => 'xxxxxxxx',
  'license_number_used' => 'mandatory,not_empty',
  'db_database_name_default' => 'forum',
  'db_database_name_used' => 'mandatory,not_empty',
  'db_hostname_default' => 'localhost',
  'db_hostname_used' => 'mandatory,not_empty',
  'db_username_default' => '',
  'db_username_used' => 'mandatory,not_empty',
  'db_password_default' => '',
  'db_password_used' => 'password',
  'relative_path_of_forum_from_webroot_default' => '/vbulletin3/',
  'relative_path_of_forum_from_webroot_used' => 'mandatory,not_empty',
  'cookie_prefix_default' => 'bb',
  'cookie_prefix_used' => 'cookie,empty',
  'user_table_default' => 'user',
  'user_table_used' => 'mandatory,not_empty',
  'session_table_default' => 'session',
  'session_table_used' => 'mandatory,not_empty',
  'group_table_default' => 'usergroup',
  'group_table_used' => 'mandatory,not_empty',
  'use_standard_groups_default' => '1',
  'use_standard_groups_used' => 'mandatory,not_empty',
  'validating_group_default' => '3',
  'validating_group_used' => 'optional',
  'guest_group_default' => '1',
  'guest_group_used' => 'optional',
  'member_group_default' => '2',
  'member_group_used' => 'optional',
  'admin_group_default' => '6',
  'admin_group_used' => 'optional',
  'create_redir_file_content' => '<?php\necho\'Hello World\';\n?>\n',
  'create_redir_file_location' => '{BBS_LOCATION}/cpg_redir.php',
  'create_redir_file_action' => 'display,write',
);
Then run the bridge manager once again and report if this fixes the issue.

GauGau
Logged

Karri

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Gender: Female
  • Posts: 44
    • The Fuselage
Re: Vbulletin Bridge Issue (cookie prefix in bridgemgr.php)
« Reply #2 on: October 26, 2004, 09:12:24 pm »

Worked perfectly.  Thanks
Logged
Thanks,
Karri

jerx

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 85
Re: Vbulletin Bridge Issue (cookie prefix in bridgemgr.php)
« Reply #3 on: December 15, 2008, 04:07:50 pm »

The current bridge manager does only have these settings:
Quote
// status: bridge unknown, manager unknown
$default_bridge_data['vbulletin30'] = array(
  'full_name' => 'vBulletin 3.0',
  'short_name' => 'vbulletin30',
  'support_url' => 'http://www.vbulletin.com/',
  'full_forum_url_default' => 'http://www.yoursite.com/board',
  'full_forum_url_used' => 'mandatory,not_empty,no_trailing_slash',
  'relative_path_to_config_file_default' => '../board/',
  'relative_path_to_config_file_used' => 'lookfor,includes/config.php',
  'use_post_based_groups_default' => '0',
  'use_post_based_groups_used' => 'radio,1,0',
);

Many bridge settings in the database are empty. Only these are set:
short_name
full_forum_url
relative_path_to_config_file
use_post_based_groups
use_standard_groups
recovery_logon_failures
recovery_logon_timestamp

Is everything else not needed any more?

How about the cookie setting? I think that is important and it is not stored in the vb database, but in its config file.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Vbulletin Bridge Issue (cookie prefix in bridgemgr.php)
« Reply #4 on: December 16, 2008, 07:26:47 am »

This is a very old thread on the bugs board that was marked as fixed. Hijacking this thread with an unrelated issue and asking for support here is silly and selfish. Locking.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 21 queries.